Return to Level1Techs.com

[Solved] [Pulse/ALSA] Motherboard line-out requires headphones to be plugged in and out after reboot

#1

Hello friends,

For some reason, after every restart, I need to plug in my headphone jack and then plug it back out in order to get my speakers (line out) to work. Does anyone know where I should start looking to diagnose/remedy this?

I have not always had this problem, I frequently run dnf update and had several kernel updates without problem. This might be a factor. Not sure.

I have supplied some info below, in the hopes that it might be useful. If you need additional info I will get more!

Thanks in advance.

System info:

Audio set-up:

  • USB audio dongle in the back (Not in use right now)
  • Headphone jack on front panel (Used to re-plug headphones)
  • Line-out on back panel (Connected to speakers)

# lspci -nnk output:

#Audio controller on motherboard
0c:00.3 Audio device [0403]: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) HD Audio Controller [1022:1457]
        Subsystem: ASUSTeK Computer Inc. Device [1043:8723]
        Kernel driver in use: snd_hda_intel
        Kernel modules: snd_hda_intel

System info:

  • Motherboard: ASUS ROG STRIX B350-F GAMING
  • Operating system: Fedora 30
  • uname -a output (trimmed): Linux 5.1.17-300.fc30.x86_64 #1 x86_64 GNU/Linux

Screenshot of $ pavucontrol:

0 Likes

#2

Do you have a way to test if the optical (S/PDIF) is actually outputing when it says it is in software?
Maybe a second PC with optical in or a TV.

0 Likes

#3

I am not sure if I understand your question fully, maybe this provides a little context:

I was able to stream to S/PDIF, although I never heard anything out of the speakers.
I then connected the speakers to my phone, and they worked there. After plugging them back into the motherboard the speakers went silent again.

Only after plugging and unplugging my headphones in the headphone jack I’m able to hear sound from the speakers. It almost seems like it fails to detect the initial plugged state (Just guessing here, I have no clue how it actually works)

Thanks for looking into this.

0 Likes

#4

I meant to say: Do you happen to have an optical cable on hand and can plug that into some playback device (a TV or DAC with optical in)?

image

0 Likes

#5

I’m sorry, I don’t have a cable like that on hand.

1 Like

#6

It looks like my profile was changed after a kernel update!

Setting it to “Analog Surround 5.1 Output + Analog Stereo Input” under pavucontrol/configuration solved it.

I can slap myself for missing this. Thanks for the help!

1 Like