[Solved] Problems updating Pop OS

Edit: Fixed with Curglaff’s solution below. Moved to top of my post if anybody is having the same problem.

@worstcaster

dpkg --configure -a

is how I fixed it

followed by

sudo apt --fix-broken install

see this link: apt - dpkg: error processing package libglib2.0-0:i386 - Ask Ubuntu

“Package libc6:i386 is not configured yet.” is the hint I think

Original problem below

I’ve been having trouble updating Pop OS lately. I had recently switched to KDE, so I thought that might have something to do with it, but after a full nuke and pave I’m still having trouble in Cinnamon. I’m running a System76 Gazelle i7-10750H GTX 1660 Ti

sudo apt update is giving me these errors:

E: Could not get lock /var/lib/apt/lists/lock. It is held by process 2775 (apt-get)
N: Be aware that removing the lock file is not a solution and may break your system.
E: Unable to lock directory /var/lib/apt/lists/

sudo apt upgrade is throwing up the following message.

Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
gir1.2-mutter-10 : Depends: libmutter-10-0 (= 42.2-0ubuntu1pop1~1656366415~22.04~8e50951) but 42.3-1ubuntu1pop1~1658401497~22.04~928bf97 is installed
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

I’ve tried sudo apt --fix-broken install and it fails due to too many error. Seems to be a problem with this library: libglib2.0-0:i386

Some other highlights from failed fix include:

Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Correcting dependencies… Done
The following package was automatically installed and is no longer required:
app-install-data
Use ‘sudo apt autoremove’ to remove it.
The following additional packages will be installed:
gir1.2-mutter-10
The following packages will be upgraded:
gir1.2-mutter-10
1 upgraded, 0 newly installed, 0 to remove and 107 not upgraded.
49 not fully installed or removed.
Need to get 0 B/183 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
Do you want to continue? [Y/n] y
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
libglib2.0-0:i386 depends on libc6 (>= 2.34); however:
Package libc6:i386 is not configured yet.

I tried running ps aux | grep -i apt to see if anything else was running and got:

root 1060 0.0 0.0 138368 9384 ? SNsl 17:30 0:00 /usr/sbin/thermald --systemd --dbus-enable --adaptive
apoptan+ 5207 22.6 2.1 1179617484 345204 tty2 SNl+ 17:46 1:33 /opt/google/chrome/chrome --type=renderer --enable-crashpad --crashpad-handler-pid=5008 --enable-crash-reporter=, --display-capture-permissions-policy-allowed --change-stack-guard-on-fork=enable --lang=en-US --num-raster-threads=4 --enable-main-frame-before-activation --renderer-client-id=12 --launch-time-ticks=981390685 --shared-files=v8_context_snapshot_data:100 --field-trial-handle=0,i,7321052516219313218,13338869811651026891,131072

1 Like

Well, if you read the error messages carefully you’d see it offers a solution:

apt --fix-broken install

Assuming PopOS uses sudo, open a terminal and copy/paste this command:

sudo apt --fix-broken install

Press enter and it’ll prompt you for your password. Type in your password and hit enter again. Now your system will attempt to rectify the issue.

[edit: Scrap it, just missed the section you mentioned doing exactly what I suggested. [email protected]! :mute: ]

Furthermore, the message about the lock on /var/lib/apt/lists/ comes from interrupting the update process by closing a window while said process is still running. Only way to avoid this is not closing that window.

HTH!

I did see and try that. The results of the fix were listed in the original post.

I’ve tried sudo apt --fix-broken install and it fails due to too many error. Seems to be a problem with this library: libglib2.0-0:i386

Some other highlights from failed fix include:

Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Correcting dependencies… Done
The following package was automatically installed and is no longer required:
app-install-data
Use ‘sudo apt autoremove’ to remove it.
The following additional packages will be installed:
gir1.2-mutter-10
The following packages will be upgraded:
gir1.2-mutter-10
1 upgraded, 0 newly installed, 0 to remove and 107 not upgraded.
49 not fully installed or removed.
Need to get 0 B/183 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
Do you want to continue? [Y/n] y
dpkg: dependency problems prevent processing triggers for libglib2.0-0:i386:
libglib2.0-0:i386 depends on libc6 (>= 2.34); however:
Package libc6:i386 is not configured yet.

Had the same problem. Give me a few seconds to find the post I used to fix it.

spit balling have you tried

sudo aptitude install

Or even to build the dependencies of said packages without configuration?

Wait… LOL hold on have you tried

dpkg --configure -a

See if packages are not configured properly and that’s what is holding it up?

3 Likes

@worstcaster

dpkg --configure -a

is how I fixed it

followed by

sudo apt --fix-broken install

see this link: apt - dpkg: error processing package libglib2.0-0:i386 - Ask Ubuntu

“Package libc6:i386 is not configured yet.” is the hint I think

5 Likes

HAHA lol I took one good look at this

And took that guess. good to know my hunch was correct. Good luck OP

“Automated Package Thrasher” (apt) at its finest hour

2 Likes

That fixed it. Thanks.

1 Like