[SOLVED] PC won't post with i5-6500, DDR4-2133 and H110M-C

Hey guys. I ordered an Intel Core i5-6500 used from ebay, tested, and an Asus H110-i/G11CD/DP_MB motherboard also tested working from eBay, and a single dimm of DDR4-2133 but when I installed them and turned the computer on, the fans spun but it didn’t POST or beep. I tried using a different PSU (500W and 430W), I tried resetting CMOS and CLRTC, I put the RAM into the other slot, I tried cleaning the CPU and RAM, nothing worked. So I got a different motherboard; an Asus H110M-C, and it did the exact same thing. I did everything I could think of. Nothing worked. I need help with this before the 15th of May (last day I’m able to return these)

At this point I think you need to try a different memory module, but you could also check for bent pins on the CPU socket.

1 Like

I had a similar problem with the same processor. I tried everything under the sun and had spares of everything else, everything but the CPU worked. The pins on both motherboards were fine and the pads looked ok, but it still wouldn’t connect right. Eventually I hit the pads on the CPU with an eraser and it’s been running good ever since. I must have tried reseating the CPU over half a dozen times, giving up in between and ready to hurl this thing in the ocean. I remember Wendel mentioning something about less than ideal silicon with some of the Skylake CPU’s and being flaky.

The old motherboard was also super flaky with bad USB, audio, and memory issues. It was in a prebuilt computer and started acting up over time. It may have not been a motherboard issue after all, but I got one for ~$30 and after fussing it finally works so I’ll call it a win.


So I plugged a speaker into the motherboard and powered it on with the memory out and it have me 1 long beeb and 2 short beeps, so you’re probably right about it being a memory problem.

I just tried the eraser thing, made sure to rub every part of the underside of the CPU (except the middle bits) with the eraser, and it’s still not working. I’m gonna order a new stick of RAM and see if that works.

I ordered new RAM and it still isn’t working. This is so weird. Anyone have any more ideas?

Don’t trust any parts as “tested and working” unless you have done so yourself, also I would consider returning everything and starting over with new prospects if that option is still on the table.


I returned everything and ordered AMD parts instead. I also found out after deciding to do so that the problem was most likely ECC memory. Both the modules I ordered were ECC, which didn’t work with the other parts. If anyone else is having this problem, make sure you’re using non-ECC desktop memory.

You did not mention it was ECC memory in your original post. You need a Xeon for ECC on the Intel side. I think ECC will work with an I3 on certain boards. On AMD, AsRock boards have ECC support. Not sure about Gigabyte or MSI. You can get the dimms and system will boot but if ECC is not supported you just won’t get the functionality.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.