[SOLVED] OPNSense force Pihole/Unbound

I think I know what it is.

In that rule you’ve set a network rather than an IP, you need to get rid of that /24 from the source address.

Yeah… I´m stupid… I thought /24 is the right one, but to specify only one host, you need to set it to /32. Let me do a quick test, if that now works, thanks for Pointing that one out.

EDIT: Yeah, you are totaly right… God damn i feel stupid, you wont belive it.
I am so thankful for you help, great work! Could also remove the Cloudflare Rule and it blocks it just fine.

If i can anyhow return that favor, let me now!

1 Like

Yeah it’s an easy one to miss. I’m used to setting either an IP or a network rather than a range. But yeah the logs are really handy for tracking down these sorts of things, I always leave logging on block rules so I can figure out what’s going on when things don’t work.

You know what the most stupid thing on that topic is ?
I try to solve this since more than 10 Hours and the default, when you select single Host or network in the rules, is /32.

That makes sense, I thought it was odd for it to default to /24 so I assumed it was just saying what the subnet mask was, but didn’t think about it enough to realise that didn’t make any sense.

Oh well, guess we all learnt something

1 Like