[SOLVED]Need a quick favor via Windows - Help BIOS recovery

Well it looks like my UEFI flashing failed in my Asus Prime X370 Pro… But I don’t have another Windows machine to make an appropriate recovery file.

Asus has a utility to do so on their support page and I was hoping someone could make a recovery file out of the 1201 BIOS for me. I can get it on a USB stick via the wife’s MacBook…

Anyone up for it? Really don’t want to go in to work for this.

Hmm, very odd compatibility issue as it turns out.

The BIOS flash didn’t fail, but something about the cheap wifi card was interfering even though it seemed to work fine on the 1201 BIOS. After flashing I got no post, no USB power, no nothing.

As no one had responded, and using the wife’s Macbook to transfer the original recovery CAP file to a USB drive did nothing on boot, I decided I couldn’t sit around and do nothing, so I removed the last thing I added: the wifi card.

Now it boots.

It would be nice to know what may cause this sort of issue as I’m clueless on that matter. Maybe this will help someone troubleshoot their boot issue someday though.

Well the card is completely incompatible with the 3203 BIOS. The GPU never initializes and there’s no USB power. I don’t even know where to start to figure out how this happens but would love to find out.

Hate to do it, but @wendell any ideas what about a WiFi card would keep a system from posting or what might be a workaround? I’m lost on this, Asus suggested I try another slot (didn’t help) or roll back to 1201 which I’d like to avoid if possible.

does the wifi card have both pcie and usb conection? try it w/o the usb conection if so. Sometimes you see that for bluetooth. What is the wifi card? Intel has some hardware that doesnt actually follow the PCIe spec. You can force pcie 1.0 and maybe work around it though.

You might also try it in the second x16 slot that is wired into the cpu.

1 Like

Yes it has a USB for the Bluetooth but unplugging that made no difference. The WiFi card is a cheapo from China via Amazon:

I’ll take a close up of the card on the adapter in a few and add it here.

Edit: it’s a Qualcomm Atheros.


@wendell The system boots in the second full slot, but doesn’t appear to detect the card.

Bluetooth is working though.

Well, apparently this is an odd one, can’t roll back the BIOS as the motherboard says they’re all invalid, or atleast 1201 and 1001. Same USB drive I used to flash both of those originally.

Try setting the pcie mode to 1.0 in uefi ? And after that try some different slots.

These cards are notorious for issues.

I figured I was taking a gamble, it’s just odd to me that it worked on one BIOS revision but not the next.

Maybe down to the bios detect/Autodetected routines. Try the pcie 1.0 thing . Can swap in a new m.2 wifi adapter too for laptops which might be way cheap. Harvest from a dead laptop

1 Like

I’ll report back on the PCIe 1.0.

Finding a dead laptop in a town of 7000 is going to be interesting :grin:

For now I have to get back to cooking.

Happy Thanksgiving, and thanks for the help!

If you find out how to reflash the BIOS to older version let me know.
My board will not boot with RX Vega 64 after AGESA 1071 bios.

Interesting. I have a flashed Vega 56 but no issues without the wifi card.


No way that I can see to set anything to PCIe 1.0. The only PCIe function I can alter is the PCIEX16_3 slot from Auto, 4x or 2x.

I set it to 2x but haven’t put the wifi card in that slot yet, although I’ll try that next.

Edit: Nope. No post in that slot.


So far it fails to post in x1_2, x1_3 and x16_3 and fails to recognize the card in x16_2. If there’s a way to set a slot to PCIe 1.0 I can’t find it in the BIOS.

User guide here: http://dlcdnet.asus.com/pub/ASUS/mb/SocketAM4/PRIME_X370-PRO/E12344_PRIME_X370-PRO_web_only_20170712.pdf

yeah, setting link speed would be the ideal thing. I am not sure the uefi on that board has the option but maybe someone with the board can look through the options.

Can you provide link to bios which you have used, or manufacturer?