[SOLVED]My OS Cannot Connect to the Network

Preface

  • PC specs listed at the end of this post
  • I researched before I posting here
  • I don’t have a recent backup of my PC

I woke up this morning and found that my computer could not reach the internet. I wasn’t to worried then, but I’ve exhausted what I know to do and still have no internet or network connection. I’m looking for advice.

What I Have Tried

  • Other devices on the network can connect: Check
  • Ethernet link light: Check
  • Trying another web browser: Check
  • Rebooting my PC: Check
  • Rebooting the router: Check
  • Verifying I receive a valid IP address: Check
  • Verifying DNS/DHCP settings are configured correctly: Check – I’ll come back to this one
  • Live-boot OS receives connection on the same hardware: Check
  • Manually setting a static IP: Check

Possible Explaination

Last night, I was attempting to create a PXE-boot server in a VM. This VM is stored on my Dell R710 that runs Proxmox. So it's not on my main PC. While following a guide, I did change DNS and DHCP settings on that VM. I don't know how this would be connected to my issue, but it seems to be a possibility.

ifconfig Output

[[email protected] technomancer]# ifconfig
enp5s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
    inet 192.168.1.53  netmask 255.255.255.0  broadcast 192.168.1.255
    inet6 fe80::3dae:551e:f78d:f46a  prefixlen 64  scopeid 0x20<link>
    ether 04:d9:f5:7d:c1:52  txqueuelen 1000  (Ethernet)
    RX packets 4713  bytes 544102 (531.3 KiB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 890  bytes 67275 (65.6 KiB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
    inet 127.0.0.1  netmask 255.0.0.0
    inet6 ::1  prefixlen 128  scopeid 0x10<host>
    loop  txqueuelen 1000  (Local Loopback)
    RX packets 29  bytes 3778 (3.6 KiB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 29  bytes 3778 (3.6 KiB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

virbr0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
    inet 192.168.122.1  netmask 255.255.255.0  broadcast 192.168.122.255
    ether 52:54:00:a6:08:01  txqueuelen 1000  (Ethernet)
    RX packets 176  bytes 13568 (13.2 KiB)
    RX errors 0  dropped 5  overruns 0  frame 0
    TX packets 5  bytes 306 (306.0 B)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

PC Specs

AMD Ryzen 5 2600x, Asus B450M-A/CMS, Fedora 31

My router is a Ubiquiti EdreRouterX Nothing special is configured on it, just setup like a normal home router.

can you share the output of these commands?

$ route -n

$ cat /etc/resolv.conf

$ nmcli dev
1 Like
[[email protected] technomancer]# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    20100  0        0 enp5s0
192.168.1.0     0.0.0.0         255.255.255.0   U     100    0        0 enp5s0
192.168.122.0   0.0.0.0         255.255.255.0   U     0      0        0 virbr0

[[email protected] technomancer]# cat /etc/resolv.conf
# Generated by NetworkManager
nameserver 192.168.1.1

[[email protected] technomancer]# nmcli dev
DEVICE      TYPE      STATE      CONNECTION 
enp5s0      ethernet  connected  Profile 1  
virbr0      bridge    connected  virbr0     
lo          loopback  unmanaged  --         
virbr0-nic  tun       unmanaged  --

If you somehow started running a DHCP server on your PXE VM experiment, it might be trying to serve DHCP to the rest of your network. If you use DHCP on the broken system, double-check that it received an address on the correct network. And shut down the VM and then try restarting the broken machine (or just restart its network). That would help eliminate that possibility.

1 Like

Well, I’m embarrassed to say, but I found what the problem was. I had turned on the killswitch for my VPN client and forgot about it.

Edit: The upside is that I learned to use networking tools more proficiently. :man_shrugging:

1 Like