Return to Level1Techs.com

[SOLVED] Mouse and Keyboard Stuttering in Games

Hi Gamers, I’ve always wanted to be a part of the growing linux community, an opportunity presented itself, so now i’m full-time linux.

I’ve been using Proton and been messing with GE’s Proton builds to play games.
I’ve been experiencing a slight issue with my mouse and keyboard.
The mouse movements don’t register and it stutters and my keyboard’s ability to register key presses/releases ‘stutter’ as well. I believe this occurs during frame-rate instability with both high and low frame rates.

Using stranglelib i can improve this issue on games that have high frame-rates by limiting my fps to something more stable. however this isn’t feasible on games where i have low frame-rates in the 30s or so.

I think my games are hogging my computer’s resources to the point where the system prioritises the game over my mouse and keyboard inputs. I’m wondering if anyone else experiences this issue or has overcome it.

I am at the moment installing more games to test
Games i’ve had issues with so far is the following:

  • Titanfall 2 - improved with limiting fps
  • Path of Exile
  • Frostpunk

Hey. How’s it going?
What mouse and keyboard do you use?
Do you have any garbage software running in the background for those? Like RGB or programmable garbage and stuff like that?

My keyboard is a Masterkeys Pro S and my mouse is the glorious model d.
Nah, i don’t have any accompanying software for the RGB or programming installed.

This sounds like an issue I used to have. It ruined a lot of FPS games but it only affected wine games. Anything native like CSGO were completely unaffected.

Could test to see if it’s just wine games? AFAIK it had something to do with the compositor. I’m using GNOME on XORG now and I think it’s completely gone as of my current kernel and distro.

I’m using KDE plasma, native games appear to not have any issues, for instance Rimworld. I’ll try out more native games later. I will get back to you later on that since its late, so for now lets assume thats true.

Plasma was one of the WMs that I dropped due to this issue. Worth noting I never had keyboard input lag like you, though. It was purely mouse and perceived FPS issues that I had.

By perceived FPS I mean the FPS displayed to human eyes. The internal counter would be reporting triple digits but I could tell it was around 30. Again this was the compositor. One of the games I got around this issue with at the time Warframe by switching between fullscreen and windowed until the issue went away. Don’t ask me how that’s just how it was but it was fairly unpredictable. It could take dozens of switching before it got it right. So glad I don’t have to deal with that anymore with whatever Gnome on Xorg managed to do. If my memory serves me, less bloated WMs like XFCE also resolved this issue. I’d suggest you try one of those or Gnome (on Xorg!) if you’re not married to your WM.

I’ll see if i can tinker with Plasma but yeah haha, time to file in a divorce soon if thats the case. thank you for your insight.

There is a keyboard shortcut to disable all desktop compositing in KDE. Don’t remember what it was but google should.

Thank you, the compositor was the issue causing it. As noenken said, there is a shortcut. its alt-shift-f12, this can be changed in the shortcut settings. Thank you everyone.

The issue came back, however i’ve resolved it. I’ve switched to XFCE4 using compiz and emerald. I was getting perceived FPS issues, resolved it by modifying the compiz compositor framerate from 50 to 75 and disabling detect refreshrate. works like a charm.

2 Likes