[SOLVED] M.2 Help

Hi All,

I have an issue, well I think its an issue with a new build. I have an Aorus x570 I Pro Wifi and have 2 x M.2 cards, one in the front and one in the back.

The issue is that the second M.2 is not showing up as a second drive in Windows 10

It was an option during install of the OS and its there in the Bios settings.

What am I missing ?

Many thanks


1 Like

Just a couple of quick checks, not much real help I’m afraid

First, I’d check the manual, and make sure neither of the sockets are disabled when any pcie socket is used.
Next I would check in Disk Management (under Window’s setings / advanced settings) to see if it is listed, but needs to be initialised / formatted before use.

Apart from that, Hope someone with this board might be able to chip in and help!


Beat me to it.

By the way. Welcome to the forum @gonutzdev

1 Like

I don’t know if Win 10 has finally updated away from the XP version of Disk Management, or if it’s still the same app.

MS are really dragging their heels migrating over to win10 apps

I’m an idiot, thanks for the help. I thought I had formatted the 2nd M.2 but turns out I hadn’t.

Thanks for helping :slight_smile: