Return to Level1Techs.com

[Solved] Linux is unstable ever since I upgraded to Ryzen

solved
#148

Sorry typo 3.75 …oops

1 Like

#149

Damn I was really excited for a second there.

1 Like

#150

Now I’m curious… I specifically remember on my old motherboard disabling IOMMU and my wifi card stopped working, but the system was stable… Hmm…

0 Likes

#151

Wait, what? You are running a wifi card?

0 Likes

#152

Yeah, occured to me that I forgot to throw it in the PCPartPicker. It’s a TP-Link TL-WDN4800 I believe.

0 Likes

#153
0 Likes

#154

Welp, fixed the PCPartPicker link.
Don’t know for sure if the card is the problem but I guess we’ll find out soon. Using a USB generic 802.11n wifi adapter.

Gonna be moderately upset if all that the problem was is a $30 pci-e wifi card, but at least I RGB-ified the system in the replacement process, which is good I guess…

1 Like

#155

Well, could have saved you two weeks. ¯\_(ツ)_/¯

0 Likes

#156

Where I have the card in my system it’s hidden underneath my GPU, so I didn’t think much of it.

0 Likes

#157

It’s most likely it, in the log you provided you can see that the interrupts are caused by ath9k which is a wireless Foss driver.

https://hastebin.com/raw/mohuvesoro

https://wireless.wiki.kernel.org/en/users/drivers/ath9k

0 Likes

#158

Welp, hasn’t crashed yet as I type this… Only time can tell though.

Pretty sure my i5 6500 was working fine with the same adapter, but only really time can tell there.

0 Likes

#159

Yeah, try your tests and give us an update when you are sure.
BTW I am definitely fan of this forum. It’s been 2 weeks and there were still ppl trying to help … It’s fucking gorgeous!

2 Likes

#160

Well you did say that the problems started after kernel update right ?

0 Likes

#161

Did you manage to sort your problem out? Was it just the WiFi card?

0 Likes

#162

Looks like it. OP hasn’t posted in a day.

Biggest face-desk moment ever :smiley:

0 Likes

#163

Yep. It was the WiFi card. Derp.
Lesson learned: make sure you check everything rather than just assuming.

3 Likes

#164

Lesson learned for sure. Oh well, live and learn.

0 Likes

#165

OP, mark this as solved! :slight_smile:

0 Likes

#166

Done.

0 Likes

#167

So if I understand your original problem it was the WIFI card that was causing all the problems in the first place?

0 Likes