[solved] Keyboard causing long boot times

I'm using a Corsair K70 RGB and it's causing my boot times to be around 20 sec longer than they should.
I fixed it on my previous computer by doing this, but I'm using systemd-boot now instead of grub. Does anyone have an idea how to do something similar for systemd-boot.

In your loader file (somewhere like) /boot/loader/entries/yoursystem.conf add usbhid.quirks=0x1B1C:0x1B12:0x20000000 to options

Are you still using Arch? Are you using the corsair drivers?

1 Like

Yeah I'm using Arch. I've only found some unofficial drivers for the keyboard but I don't use them as I only need white backlighting.

Anyway, thanks for the help. I'm going to see if it works now :D

No problem, if you do need them,this is them https://github.com/ccMSC/ckb

There are no official drivers, that's life in Linux most of the time.

If the options line works, mark the topic as solved :)

Worked like a charm :) This cut 25 sec from my boot time. I didn't expect the fix to be the same as the one for grub.

Now I just have to figure out why my uefi is taking 30 sec (according to systemd-analyze). This is outside of Linux so I guess I have to take a look in my uefi settings.

systemd-analyze blame should give an ordered list from worst the best.