SOLVED - Jellyfin nvenc driver hell

So, I went and did something a bit crazy, and decided to try and make a Nvidia Tesla P4 card work as a video transcoder (a bit overkill I admit). Anyways, I’ve tried installing every relevant nvidia driver package, but no such luck getting jellyfin to transcode it. I’m assuming I missed something obvious but its not jumping out to me.
I was getting a different error before I installed these packages:

hevc @ 0x55dfddb52000] Cannot load
[hevc @ 0x55dfddb52000] Failed loading nvcuvid.
[hevc @ 0x55dfddb52000] Failed setup for format cuda: hwaccel initialisation returned error.
libnvidia-compute-515-server libnvidia-decode-515-server 

Current error i’m fighting:

[h264_nvenc @ 0x558685351780] Cannot load
[h264_nvenc @ 0x558685351780] The minimum required Nvidia driver for nvenc is 470.57.02 or newer

It shouldn’t matter, but this is in a Ubuntu 22.04.1 LTS VM on my proxmox host, with the tesla PCI passthru’d.

I’ll probably have it figured out tomorrow, just in case anyone else had a similar problem gonna ask here…

1 Like

NVIDIA-SMI 515.65.01 Driver Version: 515.65.01 CUDA Version: 11.7

maybe the docker way is the way to go…

so, yeah
the *-server version of nvidia modules is the issue? installing libnvidia-encode-515 made it just work

1 Like