(SOLVED) Framerate Issue While Playing Doom (2016) on Linux

I recently picked up the Steam version of Doom and was able to get it to run using Wine (3.13 Staging) and Lutris. While running it with the Vulkan API enabled, the framerate would consistently drop from 60+FPS down to less than 10(?!) 3-5 minutes after launching the game.

I tested it with older versions of Wine and the long live version of Nvidia’s proprietary drivers (390), but I got the same result regardless. I uninstalled the game for now and decided to post here before reinstalling it and trying again. Has anyone else experienced this?

System Specs:

AMD Ryzen 5 1600
GTX 1070ti
Xubuntu 18.04.1 LTS
Linux Kernel 4.15
Nvidia Proprietary Drivers (396.51)

UPDATE - SUCCESS!!! Telling the CPU Governor to floor it did the trick. Thanks, FurryJackman :grinning:

You need to set your CPU performance governor to “performance.”

Makes a huge difference in Vulkan games, cause on “powersave,” your processor doesn’t even reach max frequency AT ALL…

1 Like

Thank you. I’ll give it a shot and post an update if it solves the issue.

1 Like