Return to Level1Techs.com

[SOLVED] EPYC Rome 7452 ESXi 6.7U3 Hardware RNG raw data failed health check

Hello Level1Techs Community!

This is my first post! :smiley:

Unfortunatelly its not because of a good reason…
I have received yesterday the parts to build a new server for vmware esxi composed of an ASRock EPYCD8-2T mobo, a AMD EPYC 7452 32 core cpu and 64GB of 2x KSM32RD4/32MEI kingston ram
Running the latest BIOS 2.30 from asrock and the latest BMC version too, stock settings.

everything works well, cpu, mobo ram etc, did a few tests and everything works well.
The problems appeared when i tried running what this server is supposed to be built and validated for, vmware esxi 6.7u3 install.
It boots into the pen drive with it, and it starts loading the modules, but soon after a pink screen with this error appeared:


VMWare ESXI 6.7.0 (Releasebuild-15160138 x86_64)

Hardware RNG raw data failed health check .

cr0=8001003d cr2=0x0 cr3=0xa6923000 cr4=0x100116c

*PCPU6 : 2097800/NRandomHwrng

PCPU 0: SSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSSS

Code Startt: 0x41802fa00000 VMK uptime: 0:00:00:05.507

0x451c9439bda0:[0x41801cd0b845]+0x1cd0b845 stack: 0x451c9439be40

0x451c9439be40:[0x41801cd0ba78]+0x1cd0ba795 stack: 0x451c9439bea0

0x451c9439bea0:[0x41801cc3027d]+0x1cc3027e stack: 0x0

0x451c9439beb0:[0x41801cc43bef]+0x1cc43bf0 stack: 0x430c5ad73000

0x451c9439bfe0:[0x41801cf0eaa2]+0x1cf0eaa3 stack: 0x0

base fs:0x0 gs=0x418041800000 Kgs=0x0

2020-01-31T10:21:44.123Z cpu6 : 2097799)NRandom: 541 : Random HWRNG health check FAILED

No place on disk to dump data.

No file configured to dump data.

No port configured for remote debugger.


I thought “well maybe i should just install it fresh?” and so i tried but the same error appears on the installer

i tried a previous version of it, esxi 6.5u3, the version asrock says on the website this mobo supports, and the error mentioned above doesnt appear, but i cant proceed with the install because it doesnt detect the 2 10G nics on the board, so thats a deadend too. ¯_(ツ)_/¯

its weird having this not working as in vmware’s HCL all of the hardware im using is validated to work with ESXi 6.7U3 and previous.

any help getting this to work would be immensely appreciated!

You will have to contact support as there is a beta bios that fixes the rng issue.

The nic problem is just a driver. Probably easiest to add a pcie nic for the install then get the drivers. Is it the Intel or broadcom nic?

2 Likes

oh my a reply from the tech god directly on my first post “collapses on the floor with a huge smile and glowing eyes”
thanks you very much wendell i will!
its the Intel X550 one, dual 10G ports, unfortunatelly i dont have a pcie nic to add at the moment specially one from the vmware HCL, after getting the beta bios and testing it i will see if it detects the included nics with the latest version of vmware, if it doesnt then i will have to get a new pcie nic, will post updates here in case other people have the same problem with this board and epyc rome

1 Like

You can look up the controller on VMware’s website and download the driver VIB. I know that the X550 has one officially supported by VMware, and that’s one of the niceties on 6.7 is that this driver is included by default. Not a big deal otherwise to get you up and running

Here’s the VIB for the X550 btw

thank you very much! :ok_hand:
waiting for asrocks answer to try all of this.

1 Like

UPDATE: I have received the latest test bios from ASRock Rack, the 2.52 Beta, flashing was a breeze and after that vmware booted perfectly well, no need to reinstall it again, so problem solved! If any of you have have the same problem contact your motherboards vendor and ask for the latest bios if it isnt available by the time youre reading this :slight_smile:

All NICs on the EPYCD8-2T were detected right away so didnt have the need get the drivers for the x550 or use a external NIC supported by vmware.
Hope this helps others with the same problem :slight_smile:

Tiny sidenote: After getting the problem fixed i realized a few limitation with vmware so i have moved to PROXMOX, really enjoying it altho i wish there was more content explaining everything as the documentation can be confusing.
Anyway above is the solution for vmware’s rng problem and EPYC Rome in case anyone has that problem too.

2 Likes

Problem: https://data.pingbase.de/esxi.jpeg
Solution: https://files.meyer-edv.com:3333/index.php/s/LbBAWoCKpHA7Lkg

I asked ASRock-Tech-Support, they send me the 2.52 Firmware, after updating BIOS, the Problem was solved.
I installed VMware ESXi 6.7 U3 successfully. (Sorry for my bad english)

2 Likes