("SOLVED") EPYC and Windows 10 "Hibernate" feature

Hello everyone,

I’m building my very first AMD EPYC workstation, meant to run Windows 10 Pro. So far everything’s been going smoothly… but I’m missing something very important : the ability to “hibernate”.

I’ve tried forcing it on and here’s what happened :

I have no idea what it means and therefore no idea how to fix it. Please help ! :sweat_smile:

The machine specs :

  • Asrock Rack ROMED8-2T motherboard (latest official BIOS and BMC firmware)
  • EPYC 7282
  • 4 x 32 GB ECC RDIMM (sticks are a model validated by Asrock for that board)
  • Sabrent Rocket M.2 SSD on one of the motherboard’s slots (straight to CPU)
  • Probably shouldn’t matter : GTX 970 graphics card

All drivers installed, as far as Windows’ device manager tells me. Windows is up to date.

I have read elsewhere that EPYC boards don’t support hibernation but there was no solid evidence behind that claim. I hope it’s not true, hibernation is really, really important to me.

Have you been in a similar situation ? I’d love to know what you’ve tried, what worked, what didn’t. Thanks for your help !

UPDATE : I got an e-mail from Asrock to confirm that ACPI standby modes S3 and S4 are not supported and there is no plan to support them. As far as I’m concerned the matter is closed. When you don’t use the PC, it draws 65-70 W from the wall according to my UPS. If you can live with that, it may be acceptable to keep the machine on 24/7. Otherwise, your only option is to learn to live without hibernation.

Hibernation is hidden on all machines by default. Please, try enabling it this way and you should see the option appear in the power menu. Perhaps, the firmware lacks support for it as it says in Powershell.

image

I don’t see any ACPI settings to allow or deny going into sleep mode either. Please, check on your machine to confirm that there aren’t any available either.

First thing I’ve tried (this ain’t my first rodeo). Here’s what I see, it’s pretty limited :

I’ll contact Asrock and see if they can help me with this. I don’t even see why the motherboard / BIOS have to be involved since it’s basically about writing the content of the RAM to disk, and then restoring it from disk to RAM.

It must be some limitation or lack there of ACPI compatibility with the BIOS. Since servers generally run 24/7, they might be omitting such sleep/hibernation options on purpose.


You don’t have sleep support, and this probably proves my point, or there might be chipset driver configuration problem which is highly unlikely. You shouldn’t need chipset drivers, IMO, since all the power/sleep should be handled by the firmware’s ACPI portion and the OS.

I think it must be related to power states enabled in the BIOS.

I wasn’t aware that Hibernation relied on power states but there must be something. Maybe it is related to Hybrid Hibernation which hibernates and then places the machine into Sleep for a few hours.

I would not be surprised if EPYC defaults to no power savings. It’s a server CPU and deep power saving does not really make sense.

I’ve looked into it. With Windows, things are a bit complicated. In the absolute, hibernation may require ACPI support (so-called states S3 or S4) however, as I suspected, an OS should also be able to implement hibernation on its own, and Windows has been doing it for a long time under the name hybrid sleep. The EPYC BIOS is a maze of hundreds of options, most of which are unexplained and incomprehensible even though I’ve been rummaging through BIOS’es since the Intel 386 era. So I decided to give it a rest and look on the Windows side. Here’s a nifty command I discovered, and its result :

image

Now, at this point the machine has only two graphics adapter : a GTX970 that has never prevented hibernation on other machines… and the AST2500 IPMI.

I’m going to look deeper into this. I hope I’m on to something.

The plot thickens…

I’ve set the BIOS to use “external” instead of “on-board” VGA. The on-board VGA disappeared from Windows’ device manager and now I get this :

3 - IPMI graphics disabled in BIOS

By comparison, here’s what it looks like on my current workstation :

image

So it appears that Standby state S3 is what I require.

The quest goes on…

Minor progress to report : I found out the cause of the “graphics disabled this standby state” error and fixed it. It turns out that whatever driver Windows 10 automatically uses with the IPMI’s graphics adapter is inappropriate. I’ve installed the ASPEED VGA driver v1.06 for Windows Server 2019 instead and the error went away. I can now use the onboard VGA during boot and, once Windows as started, as a second monitor.

This hasn’t fixed the hibernation issue. If it’s truly a lack of proper ACPI support in the BIOS then there’s probably nothing I can do except find a way to make Asrock implement it. This is making me wonder exactly how hard it is to implement ACPI, considering even the lowliest Z-tier motherboard manufacturers have no problem doing it.

Final update : I got an e-mail from Asrock to confirm that ACPI standby modes S3 and S4 are not supported and there is no plan to support them.

2 Likes

Hello Nefastor, since I am building a workstation with the same ASrock board - I just want to know if you Windows10 pro works with it without issues and stability issues? Planning on running RTX 3090 with it and Creative Apps! Thanks!

Hello @Edin_Gacic ! Yes, it works perfectly fine with Windows 10. Note that you will need to download the EPYC SP3 drivers as it seems Windows doesn’t download them on its own but other than that everything is fully plug-and-play.

I’ve had no stability issue whatsoever except when I used the Milan BIOS update with a Rome processor : it works but is unstable. Make sure to update your BIOS to match the processor type you’re using; you shouldn’t assume that the latest BIOS will work with any EPYC.

I have run it with a 3090 FE myself and that comes with mechanical issues : those cards are very heavy, and the motherboard has plastic PCIe slots, non-reinforced, and surface mount. It’s a server board so it’s not meant to be mounted vertically in a tower case.

Also, the PCB is extra-thick (12 or 16 layers, maybe) so your motherboard tray screws might be too short. Be careful with that. You may need to use longer screws with the same thread, I used screws for optical drives, for example.

On the software side, nothing to say : it all works beautifully. If you haven’t already, you should go through the EPYC Milan workstation thread, I’ve contributed photos (including thermal) that you might find useful. As well as a lot of information by lots of people including our Lord and Savior @wendell :

where can I get these drivers? - I am preparing everything when it arrives to install it smooth. I read your other thread and I remember you said somewhere on SuperMicro site? I guess I have to make sure its for Milan? I wanted to go with SuperMicro board but one distributor said that windows 10 has blue screen and stability problems with it. So I was happy to find your post and AsRock board and to learn that you have been running Windows 10 and also Resolve without problems :slight_smile: What is the deal with thunderbolt I asked the distributor and he will talk direct to AsRock to see whats up. Did your board come with the header soldered? Would be nice if thunderbolt 3 worked but not a big deal if it does not .

Oddly, they don’t seem to be on AMD’s website or Asrock’s. Like most people (who didn’t buy their EPYC machine pre-built) I downloaded them from SuperMicro :

https://www.supermicro.com/wdl/driver/AMD/SP3/

It works with Rome, not sure about Milan. This contains stuff like USB drivers that might be common to both.

1 Like

It did not. I’m not interested in TB so I didn’t really look into it but there seems to be licensing issues with Intel, plus this is more of a workstation interface and that motherboard is clearly meant for servers (despite what the box says).

IMHO, if you want TB you will probably need to use a dedicated PCIe expansion card.

What do you use TB for ? Displays ?

I don’t have any TB devices because my dino z800 has not even usb 3 :slight_smile: So I also don’t care but would be nice to have TB3 to add some devices in the future for easy plug and play I guess. I will eventually run multiple GPUs now Its single RTX 3090 FE that I got for MSRP price I was lucky - I sold 2080ti at the right time and got it on Nvidia german site without VAT so it cost me 2080ti plus 450 eur :slight_smile:

Same thing here. No one ever believes me. Crazy times to be alive, bro ! :sweat_smile:

1 Like