Return to Level1Techs.com

[SOLVED] Displayport 4k display issues

linux
helpdesk

#1

I'm having some issues with my A409U running off a R9 380 through displayport.

When I plug the monitor in through HDMI, it's working fine, but limited to 24hz.

The monitor, through DP ([email protected]), seems to work fine in Windows, if I set 8 BPC. Not sure if that's relevant.

In linux, it's not the monitor that's causing an issue, it's more of the GPU drivers (amdgpu on Arch x64, kernel 4.5) There were kernel messages that I saw last night:

[drm:amdgpu_atombios_dp_link_train [amdgpu]] *ERROR* channel eq failed: 5 tries
[drm:amdgpu_atombios_dp_link_train [amdgpu]] *ERROR* channel eq failed

When I have it plugged in through DP, xrandr reports that it's trying to display at [email protected], however I get a no signal notice on the display.

When I'm looking in the cinnamon-settings display window, the kernel spits out the following:

[drm:amdgpu_atombios_dp_link_train [amdgpu]] *ERROR* channel eq failed: 5 tries
[drm:amdgpu_atombios_dp_link_train [amdgpu]] *ERROR* channel eq failed
[drm:amdgpu_atombios_dp_link_train [amdgpu]] *ERROR* channel eq failed: 5 tries
[drm:amdgpu_atombios_dp_link_train [amdgpu]] *ERROR* channel eq failed
[drm:amdgpu_atombios_dp_link_train [amdgpu]] *ERROR* displayport link status failed
[drm:amdgpu_atombios_dp_link_train [amdgpu]] *ERROR* clock recovery failed
[drm:amdgpu_atombios_dp_link_train [amdgpu]] *ERROR* displayport link status failed
[drm:amdgpu_atombios_dp_link_train [amdgpu]] *ERROR* clock recovery failed

I've also got a GTX 660 ti that has displayport, and according to the nvidia website, it's supposed to have DP1.2, however, I haven't tried it yet.

Any ideas?

EDIT: So it seems like the AMD drivers are entirely at fault here. For anyone else encountering these issues, if you have an available Nvidia card (mine is a gtx 660 ti) that supports [email protected], give it a try with the proprietary drivers and see if that works. Hopefully the kernel devs will be able to get these issues sorted soon.


#2

Try setting it to 1080 and back to 4k with xrandr and see if that helps.

https://bugs.freedesktop.org/show_bug.cgi?id=86320


#3

Checked if its the cable giving you issues?
The cable that came with my monitor liked to throw a fit.


#4

@reikoshea I'll give that a try when I get off work.

@Castellorizon I've tried the one that came with the monitor and a 12 foot cable that I picked up from Amazon.


#5

@reikoshea I got it to display once at 1080, had to use the following:

# xrandr --output DisplayPort-0 --mode 1920x1080 --rate 60

running the following:

# xrandr --output DisplayPort-0 --mode 3840x2160 --rate 60

Gave me a no signal with more link status failed kernel messages along with the channel eq failed messages.


#6

Now I'm curious if rate 30 works at 4k.


#7

I tried that after posting and it didn't work. I basically tried all the resolutions that xrandr reported for it, and anything below [email protected] would work, and anything above would not.

I do have a secondary monitor, not sure if this matters though, it's running off DVI-I-1 at [email protected]


#8

The cable that came with my A409u was garbage and I just chopped it into pieces.

@sgtawesomesauce Get a new cable if you haven't already


#9

That's what happened when I used that (the cable that came with the tv) cable to connect the monitor to my laptop. The other cable I have (purchased from amazon, I'd heard bad things about the cable before) shouldn't have any issues. I was able to get [email protected] working on Windows 10 with the latest crimson drivers, but only with 8bpc set, if I went to 10 or 12, it wouldn't display.


#10

it may be a digital signal but you should always have a spare wire. this will help when you have to debug. just grab one off amazon or ebay, maybe your local brick and mortar.

i'm also pretty sure most monitors are 8bit. 10 bit and 12 bit are usually professional monitors for color grading work. try setting it to 8 bit. also amd have color space settings. 4.2.2 or 4.4.4, again most monitors are 4.2.2. so check for this in the nvidia gui.

set it to 1080, 8 bit then 4.2.2 . the try changing the resolution.


#11

I thought two would be enough: the one in the box with the monitor and the one from Amazon.

I don't know much about monitors, so as far as 8 bit color settings, I'll defer to you.

I know this monitor is supposed to support 4:4:4.

I'm using an AMD card currently. Should I switch to the 660ti?


#12

i believe driver support on older cards is better. i have a 380 as well. but i only have a 1080 monitor.

yes 2 wires is more than enough. although once you've established that a wire is no longer useful you should dispose of it. i had problems when i kept too many old hdmi cables. was hard to establish the problem.

why dont you try first with the 380, put it to 8 bit and 4:4:4 1080 then switch it up to 4k. if it doesnt work try switching up in intervals using the custom resolution setting. try putting the refresh to 59hz or any accepted values >60.

sometimes the monitor will not accept the actual refresh rate sent by the gpu. i know this to be true with madvr. i have to manually set refresh rate to 59.98hz.


#13

I've had no issues with this card. I hear driver support is a mess on the Ubuntu/Debian side of the world, but here in Arch land it's all sunshine and rainbows.

I'm not sure how to force 8 bit and 4:4:4 on Linux, so I'm stuck there. I've been busy this past weekend, so I didn't have much time to look into this. I'm looking around and it seems like the best method set 8 bit is is the "Depth" option in xorg.conf. (setting depth to 24 should be 8bit)

I'll try this now and report back.


#14

So, I was able to set the depth to 24, which should be 8 bit, but I was unable to get the monitor to display, over displayport at anything over 1080p No matter what mode I used, it wouldn't help. I couldn't even get [email protected] to work. I'm continuing to get the same errors as posted in the thread above, so I'm thinking it's a driver issue.

I'm in the process of switching to the proprietary drivers to see if that helps it at all. So far, I'm not getting far. The good thing is that with catalyst, I can get the errors in dmesg to go away. The bad news is that the monitor reports 8192x2160 as the resolution catalyst is pushing and I'm getting a black screen.


#15

Just so people who are interested know, I was able to get 2160p @ 60hz by using my GTX 660 ti with the arch package linux-vfio for the kernel (linux 4.4.5-1 with some Passthrough related patches), and the Nvidia proprietary drivers. Having some minor issues with screen tearing, but it's early in the configuration stage, so it's probably a little early to complain.