Return to Level1Techs.com

[solved]Configure Xonar STX for Linux/Ubuntu

linux
helpdesk

#1

Ive just switched the last of my computers over to Linux but I need some help configuring the audio side of things.

Hardware
Asus Xonar Essence STX - 24 bit 192000kHz capable dedicated sound card.
Powered 2.0 stereo speakers - connected via RCA cables directly to sound card
AKG K712 Pro headphones - 64Ohm impedence - connected directly to headphone jack on rear of soundcard (I dont use front panel jacks)

How can I configure my soundcard in Ubuntu 18.10 to the ‘optimal’ settings? Right now everything works, but the volume level is MUCH lower than in windows 10, and audio seems lower in quality (I’d say thinner if I had to try and explain it)

I am still learning Linux, so Im happy to provide any info needed to configure this but please be explicit and verbose in your requests.


#2

Alright first things first, Lets talk some basic sound knowledge before getting into linux.

Signal processing wise audio cards are basically going to follow the processes we use elsewhere. Heck we used them to make oscilloscopes back in the day. Now one of the problems with oversampling or sampling very high to rates such as 192K is that it can create something we call harmonic distortion. This is very detrimental to our hearing experience if it gets too high. Naturally lets explain where 44.1 comes from. The human range of hearing can at maximum extend from 10 Hz to 24Khz roughly. Now MOST people do tend to hear within 20 hz to 22050Hz. So this 44.1 khz rate comes from something we call the nyquist rate. This little bugger is the reason verizon likes to limit your bandwidth because in radio signals this acts as an upper bound for the symbol rate across a bandwidth-limited baseband channel or frequency devision mulitplexed signal. Thus if you saturate your rate by too many users on one divsion… WELL you get drop outs and a lot of other issues… Now with sound it acts as a lower bound for the sample rate for alias-free signal sampling which means as long as your above this sample rate you will not encounter artifacts or distortions. The laymans terms is that 2*22050 is 44.1. Some people are pretty super human and can hear upwards of 24000 which makes 48 Khz sound our ABSOLUTE maximum capability of distinguishing as humans. Now that being said usually two times your maximum is where you would ideally like to sit which leads most people to 96Khz. Now the biggest problem with going further is that this is only used for production.

Bitrate is also a factor but given the problem that most artists are always maximizing their gain on 16 bit audio the upgrade to 24 bit is usually wasted as the higher the maximized gain the lower dynamic range which makes higher bit values for more range wasted etc bla bla lets get into the config.

i recommend 24 bit 96K so lets start here.

One I recommend since you are not experienced that we start with pulse audio. This is the default sound server found on almost all distributions. @Kocytean I need to know. What time zone are you in because its definitely time for me to sleep soon LOL


#3

I am in Australia - GMT +10


#4

Well good day to you LOL. its almost lunch time for ya. Tell ya what let me finish my work briefly on something and Ill get back with linux instructions.


#5

No prob, its currently 7.45 PM here, ill be up for ages, and around tomorrow as well. no rush.


#6

I did my math wrong… years of working with way to deep and abstract stuff has well made my easy math rusty haha… I may have to resume in the morning given it is the morning haha should I not respond tonight… But I will definitely see if I can put together something more straight forward.


#7

Made a few changes and I think I found and fixed one specific issue.

Edited pulseaudio - I’ll add a screenshot

Opened ALSAmixer in terminal and found that my headphones were set to <32Ohm and switched it to 64-300Ohm and its much better, as far as im concerned Headphones are sorted.


#8

Impedance is everything on the line because its not just resistive loss. Yes I was going to ask you to make sure the impedance was set properly.

Now for the next order of business change you resampler in the pulse config to the highest quality provided by your system


#9

Ok - so how do I determine the highest quality and then set it to that?


#10

well since others have been deprecated… roll with speex level 9 or 10


#11

So by that do you mean editing this line in pulseconfig

; resample-method = speex-float-1

to

; resample-method = speex-float-9


#12

Yes … sorry I got caught up bullshitting in the lounge. you got lost in the notifications hahah…

do speex-float-10

since you have stereo devices. lets make sure ALSA doesnt sample back down

down vote
Alsa by default uses the same sampling rate and format as the source. It is however possible to force the sample rate up (or down).

Modify in /etc/asound.conf but make a backup first
add this

pcm.device{
        format S24_LE
        rate 96000
        type hw
        card 0
        device 0
}

Then just make that pcm a slave to another device.

pcm.!default{
    type plug
    slave.pcm "device"
}

replace device with whatever your device actually is… I assume you can enumerate them already?

for example for my surround 5.1 I use this

pcm.!default{
    type plug
    slave.pcm "upmix20_51"
}

you could put in place for device hw:0,0 this will use your default always


#13

@Kocytean did you figure it out.?


#14

I think so. Ill run with this config for a bit and see how it goes. Thanks for the help.


#15

Np at all marking solved


#16

apologies if i misread this from earlier posts,
but appears to be something i have seen other people have a problem with

the semicolon “;” at start of the line acts like a comment tag
you need to delete the semicolon or the setting is ignored

I have known other people caught out by this
not surprising when most if not all settings are commented out
and another main Pulseaudio file in same folder (default.pa) only uses “#”

also suggest if you expect to do a lot of changes to Pulseaudio configuration:

  1. copy /etc/pulse/daemon.conf to ~/.config/pulse/daemon.conf

  2. leave original system file alone and only change settings in home folder copy

  3. reload Pulseaudio to load new settings

this made tuning settings easier and quicker
(or rolling back to system default easier if you mess up!)
and i can usually pull the home folder configuration into most new distros with no changes