[SOLVED] Cannot boot from centos usb

Hello sir/madam,

I cannot boot centos 7 minimal iso contents from my usb. I tried 2 motherboards and 2 usb sticks. Ask for more info, I’ll be on in 14 hours from post.

Thank you in advance.

Solved: I used Rufus to install minimal iso onto the usb stick. I had legacy on.

What are you using to build the USB?

If there is any other information you think is relevant that you can provide that would be cool.
There is a great tool for creating a live USB called Etcher.

If you’re on linux and want a package manager to handle the install you might have to find an appropriate repo for you distro.
Make sure the USB your writing the image to is big enough for the ISO file
Lastly, for some computers I’ve found that I have to enable legacy boot for some live USB’s I’ve made. This is usually a setting in your BIOS (something like “Boot Mode: UEFI”, try setting this to legacy or CSM)

1 Like

He should of provided to begin with.

Anyways, onto the task at hand. Since I will assume you are using the windows system you’ve mentioned in the past, I would recommend what @Painkiller has listed or rufus, you can find the software here:

Rufus is quite nice because it can make most USB UEFI compatible and the software is relatively brain-dead to use.

1 Like

I’m not using any software to burn/write, have installed plenty of systems this way and corrupetd no usb sticks like I have done with win32 writer.

I do not favor that kernel.

This is a completely new system I’m installing centos on.

I enabled legacy usb boot it did not work.

I’ll check that


Edit: I got it working with rufus, I hope the usb doesn’t brick.
Thanks to you. Painkiller you are invited to the credits page on nxtgc.ddns.net/credits.html

Your link is broken.

1 Like

I’m sorry, the server is updating at the moment.