[SOLVED] Bought X470 AORUS GAMING 5 WIFI - Bios Update Recomendation

I use Linux exclusively, Windows is not even an option for me as a Daily Driver

Bought X470 AORUS GAMING 5 WIFI With R5 3600 - Still in shipping
So naturally need to update bios,

In the process of update it says

  1. If you are using Q-Flash Utility to update BIOS, make sure you have updated BIOS to F31 before F40
  2. Before update BIOS to F40, you have to install EC FW Update Tool (B19.0517.1 or later version) to avoid 4DIMM DDR compatibility on 3rd Gen AMD Ryzen™ CPU.

I will install and update EC FW Update after installing windows just for that.

F31 bios doesn’t have any requirements like F40, So i can use the qflash.

F30 Bios says

  1. Update AGESA for Athlon 200-series (Raven2) APU and further new CPU support
  2. Improve USB compatibility

Note : Update AMD Chipset Driver or later version before update this BIOS

Question are(In the end i need this to work with Linux)

  1. Can i update to F31 then F40 or F41 after EC FW Update Tool

  2. AMD Chipset Driver F30 update is required, can i skip this ?

  3. Looks like they are pretty serious about AMD Chipset Driver windows is okay how about Linux does amd-firmware package in Debian buster include this, Or is it included in archlinux. Or is it okay to skip it completely and Linux will work.

Asrock Taichi was my first preference but no dedicate service centre locally . Gigabyte and Asus is the one who has dedicated service centre locally and they are pretty good in repair or RMA time

1 Like

Is that util really a windows program? I dunno how big it is but you might be able to get it to run with Freedos. I had to do that for a Supermicro bios update a year or so ago. I forget the details, but I think I can probably find a wiki page that might be helpful…


It’s a bit of a rabbit hole as there are many ways of going about it. I think the arch wiki links to a couple gentoo pages too. In the end I had to download freedos directly and make my own image/usb because the other solutions were using partitions/filesystems too small to hold the bios update. Ymmv.

If it really is a windows application… well my condolences. I know your pain I didn’t want to have to spend the time loading Windows on that box either. Though truthfully I might have spent as much time or more making my freedos boot image… but hey! I saved it for next time I have to do something like that.

As for the Chipset Driver it’s probably fine to ignore? As long as you use a fairly up to date kernel. Dunno. That’s hard to say. Though I think the bigger worry is if you’ll have problems with the bios that turns on PCIe support?

edit Oh, I just downloaded it to look. Website says Win10 and the archive has a couple .dll’s (one is flash? ewwww). The only small ray of hope is if one of the two .exe’s is simply a GUI front end for the dos based flash util. Dunno if that’s the case.

edit Yup, I need some coffee. Flash as in flashing the bios I imagine and I thought flash as in the zombie adobe product that just won’t die.

edit Just noticed something about the name of that update and the first option in that wiki page I posted. Notice any similarity? -
https://wiki.archlinux.org/index.php/Fwupd (ate)

1 Like

Name of the exe is ECFwUpdate.exe and one IFU_XE32_v1310.exe has 6 .bin files also . I think its GUI based program. And its major step in bios update from f31 to f40. People who didn’t do it and update from 31 to 40 had some major problems with sound total disabled on this board. Not sure if it allow command line options will check it out on my old board to see if command line is available. From review i read it seems reset the bios to f2 or f4 then can only then can flash f40 of f41. Because its being a major part of bios update don’t want to take risk will go for a windows install then update to f41 then restore my Debian image back.

My choice Ryzen 3600 is going to suffer on Linux due that systemd problem and thermal monitoring sensors not been read, I am using Debian 10 so i should not be effected by systemd well thermal are only coming back on kernel 5.4 at that time i might have to go to arch.

Major concern now is i want to do the update as perfect as possible so in future i can rule out bios update was the cause of any issue i may encounter.

For a crazy scenario i had, no one seems to have this on web, Well no one i found had my config. This is why i had to purchase new mobo, processor and PSU. I seriously thought that had damaged some of hardware somehow.

Asus Rog b350-f had a bios update it said you should have latest amd chipset driver and nothing else. Installed it using bios utility. Then the problem started while gaming the space invader artifact came, Then after hard reboot will post and where it starts GDM or NVidia Prop Driver It hangs and give 10 beep then 11 beep. Beeps are so fast I tried recording the sound still can’t make out how many could have been 8 and 11.

So google told me my graphic card was damaged RTX 2070, Tom hardware user told me my PSU was not adequate so ordered a PSU. As a test Changed PSU to not so high end one Crosiar CX series still problem continued. So thought Motherboard was having problem so ordered CPU and motherboard(My work revolve around a sound system been available) .

i asked users locally if anyone has same b350-f rog motherboard and one replied i went to his place he was kind enough to test it in his system. And it worked perfectly (PSU and Graphic card, CPU). So bios i flashed was 5008 and his bios was 4207 so i came home happy thinking i can flash back that bios and i am done. tried install that version with asus ezflash didn’t allowed me to flash it saying not a valid bios. I started downloading all except last 2.none work. Asus has blocked the downgrade. So i took freedos and converted cap file to bin and tried ami bios tool even that tool didn’t allow to flash the old bios.

Only Bios i am able to revert to was 4801 which was released same day as 5008 with newer CPU support. Which booted the system but same artifacts happens on steam play(proton games) games like within 2 -3 min. Native game got more mileage say few hour. So i am blaming the bios here. And something to do with memory no sure no information available.

I will try the arch wiki said tools on Asus rog, just love the arch wiki. Let me read it and try to understand it. if I can get it to older bios I can use it as a server for my lab VM’s.

Dont want to mess up new system also.
This became kinda long reply,

Thanks for replying

Whoa, so this upgrade to the gigabyte was prompted by a… well series of unfortunate events starting with a machine imploding due to what seemed to be a power problem and ended with a bad bios flash (or at least no path to downgrade).

Sorry dude. Kinda feel like going with X570 would be less of a potential nightmare, but I’m sure there are issues there too so what can you do? Not to mention I know what it’s like to stubbornly be focused on getting something to work. Not sure you can return the gigabyte at this point either.

I tried to return this and purchase Asus prime x570 with csm. Supposed to be aimed at enterprise customers so should be solid, but product is already in shipping (gigabyte) , I didn’t buy it from Amazon, Amazon returns are so convenient. Didn’t want to take risk in purchase as gigabyte, Asus and most others have one online retailer in India. I bought it from them, there return policy is shitty. If I return they will take shipping cost and money will be credited back with in 14 days, that’s too long without a pc to work on. My laptop doesn’t have enough power for my needs.

Well let see what happens, I am pretty sure I did my reaserch on bios update right, I did raise my concern regarding bios to the dealer he offered that he will update bios from there service center I said ‘no’ because I want to know what all happened to the motherboard and didn’t want an open box, so they have said if bios fail take it to gigabyte service center close to my place and they will fix it.

I hate x570 extra fan design, it just seems like propped to fail in some point in its life don’t think it’s user replaceable, it’s tiny fan. X470 though should be much mature than x570 which just launched.

Will update within 2 weeks if no problem encounter, if it crash and burn will update within 3 days.

I have put an support email to gigabyte so just to be sure my steps are correct, waiting for there reply.

Well, I can’t deny it bugs me too. Especially the more bombastic Mb designs that attempt to cover the fan with a mesh or grill. It’s one of the reasons I’m preferring the Gigabyte 570 boards as they at least look easy to blow the dust out of when you do some spring cleaning.

1 Like

Gigabyte replied and the tool can be used on free-dos, they have sent me the tool also. I wanted to paste their reply here, it have some links to the tool. I don’t have permissions to post links here as of now. Would have been useful for others.

Glad that I can skip windows install now…

Gigabyte reply bellow, the tool can be used to flash any v***.bin files in free dos. Gigabyte recommended bellow V684.bin to be flashed.

We suggest you update BIOS to  F31 and then ECupdateFW then F41 using Q-Flash tool and below link is for your reference:


As for EC FW dos tool, please download the [ECFW](https://esupport.gigabyte.com/FileUpload/Answer/2019/8/735583/ECFW.zip) dos tool and here is the commands: IFU309B5.EXE V684.bin



Good deal. At least they aren’t like Supermicro and suggest using a HP Utility through a broken link for Bios updates… Freedos ftw

I am marking it as solved as bios flash how-to is solved. Pretty good at flashing gigabyte Bios Now .

(how to update). Steps

  1. insert R5 1600
  2. Q-flash F31
  3. IFU309B5.EXE V684.bin (free-dos, with IFU309B5.EXE V684.bin in boot USB)
  4. Q-flash F41
  5. insert R5 3600

Also The board came with F40 out of the box.

Bellow might be useful for others.


Debian Buster - WiFi Didn’t work, I am pretty sure it will work with little effort.
Linux Mint 19.2 - WiFi worked out of the box

Systemd(with nouveau)

Didn’t have systemd problem with this board.
(Livecd)Popos 19.04 booted, Manjaro (xfce rc1 and gnome stable) Booted, Fedora 30 Booted.

More over i just love that i can control RGB from bios.

I am on F42a Bios

So same problem with the gigabyte board Black Screen while loading Nvidia driver. Not sure whats going on maybe the current state of Bios with zen2, maybe my graphic card is actually damaged. I have RMA’ed the Graphic card. Glad i have 3 year of MSI warranty. This happened within 8 months into warranty. Maybe i have micron memory controller maybe i get Samsung one. All maybe’s(Hope).

I am getting a low cost GPU which can be used until the RTX 2070 returns.

Good thing they weren’t just talk and it worked for you. Incidentally I saw a headline that gigabyte removed PCIe 4.0 support from their bios. That’s probably a good thing tbh.

It is indeed good that you stuck with the X470. I ended up on an X570 board in the meantime. While I don’t regret getting a free replacement board for an X470 that was having issues. I do regret having to wait for a bios update now that my VFIO setup broke.

gigabyte removed PCIe 4.0 support from their bios.

F42a - Description says removed PCIe for certain 3000 series processor. I am on F42a, still have option in bios to select gen4. Don’t care about pcie4 though.

VFIO - Not sure about this board, if it’s broken or not, Havn’t done any pass through with iommu. When I get my rtx 2070, planning to test iommu. I want to try a video editor which I used 4 years back in windows. Wine doesn’t help.

@GiBu_GeorGe Could you share your IOMMU groups please… Need info to decide if this is the board for me. Thanks

I’m very late to this thread but I just went through this hellscape and have something to add if any others need a working solution.

The setup is an Aorus X470 Gaming 5 WIFI board with a 2700X CPU. The BIOS was F5 when I started and I successfully have Fb3a running now.

The system as a whole is a little old so I wanted to update it for my son to last a few more years. The idea was to get a 5800X3D and new GPU but the BIOS needed to be updated — and as outlined above, Gigabyte really makes it clear you need to:

[1] update to F31
[2] install ecfwupdate_B19.0606.1
[3] update to F40
[4] update to Fb3a (in my case to support the 5800X3D)

Anyone reading my reply right now has probably discovered that there are ZERO answers out there for getting past the ecfwupdate_B19.0606.1 stage which always ends with “Load Flash.dll failed!”. In many cases people appear to become so frustrated they simply updated the BIOS anyhow and downgraded to 2 sticks of ram.

Anyhow, I came across an answer on this page:

…it’s the only answer which actually made sense and actually works. You can read his answer but here’s the meat of it:

"In the download zip there’s a file called Uiset.ini, ini files are generally used to initialize .exe files with specific values , this file does control IFU_XE32_v1310 behaviour. I don’t even need to use the ECFwUpdate.exe program.

The issues seems like it is not automatically loading the correct file so I just set AutoFlash=1 to 0 and it does indeed correctly launch the program, but I need to manually select a .bin file."

[1] I followed his example by editing the uiset.ini and changing AutoFlash=1 for AutoFlash=0.
[2] Next, I ran the IFU_XE32 app (not ECFUUpdate)
[3] When IFU_X32 loads it allows me to choose a bin to install
[4] I choose v615.bin and load it, after 30 seconds the PC reboots.
[5] Everything still working so I run IFU_X32 again and load v817.bin, after 30 seconds the PC reboots again
[6] Everything still working so I made it through the EC FW hellscape!
[7] Reboot to BIOS and it’s reverted to F5 which WAS expected
[8] Update to BIOS F31
[9] Rebooted and everything works. Reboot to BIOS…
[10] Update to BIOS F40
[11] Rebooted and everything works. Reboot to BIOS…
[12] Update to BIOS Fb3a
[13] Rebooted and everything works.

Fb3a is the recommended BIOS for the 5800X3D so I’m stopping there even though there are 2 more revisions (I’ll wait until there are no trailing letters).

Tomorrow I plan to pick up the 5800X3d now that the board is successfully updated to host it.

Thank you!
i have a gigabyte AB 350 gaming 3 motherboard on F23, and was trying to upgrade to the latest version. I am running windows 11 and I got stuck with this exact error and couldnt find a single forum that explained what this error was or how to get around it. This approach helped me finish the upgrade!

gigabyte bios update… apply the ecfupdate tool
once done you can update straight to the bios you want.

no need to update to every bios in sequence till you get to the one you want to use…


also i would recomend you use the update alt bios also function.