[SOLVED] Antergos wont boot :-(

Hi Level1Tech,

Wondering if one of you wonderful people would be able to help me.

My system wont boot :frowning:

I am getting this error https://imgur.com/a/uWGy0 (p.s. this i
s not my photo, but it is my error)

this all happened during an upgrade that crashed halfway through.

I’ve managed to chroot into my encrypted drive using a live usb but i’m unsure of what to do next and I may have chrooted improperly?

Anyway i tried pacman -Syu from the chroot but pacman says it can’t find mirror.db.

Any pointers would be greatly appreciated.

if it crashed halfway through, you may have serious issues with your drive, backup your /home directory then reinstall and just pop your home directory back in.

If you want to make your life easy, get a package list so you know what packages to reinstall:

pacman -Qe > packagelist.txt

When you reinstall just choose the same username and it will reuse all your configs etc after you copy your old home dir back in

Happened to both of my devices running archlinux. Somebody must have royally screwed up.

I fixed it by rebooting into the installer and then reinstalling all of the packages.

did it happen recently?

Yes. Both of them happened one or two weeks ago. The PCs crashed in the middle of the update and refused to boot.

That sounds like my bug!

How did you fix it?

@jdfthetech: thanks. That sounds like the nuclear option but it may be the best solution yet.

I booted into the archlinux installer and mounted all of the partitions. Then arch-chroot <wherever-your-partitions-are> and use pacman to reinstall broken packages. I reinstalled linux and a few others I don’t remember.

Then recreate the initramfs mkinitcpio -p linux

This gave me a bootable system, but some packages were still broken. I reinstalled everything using pacman -Qnq | pacman -S -

That’s it.

Yeah that’s what my thought was to do, but I’m having troubles. I think I’m not chrooting properly or something. Do you think I’d need to mount a swap partition?

No, you can’t mount swap. If you’re having trouble follow the installation guide.

I’ve made progress. I’ve managed to finish the upgrade. I don’t know why it wasn’t working before, maybe the mirrors were down.

Gonna try reinstalling linux, linux-headers and virtualbox packages. then do the mkinitcpio…

I’m feeling confident.

Really appreciate your help

We’re back!

Thanks for your help. It was the hand-holding I needed.