[Solved] 280x Not Posting!

I have a bit of a problem here and want to know what you guys think, before I start ordering parts I might not need. 


Updated from an AMD 6850 to a 280x. My brand new 280x is not posting on my machine. I plugged in everything correct and the two little leds above the 6+8 pin light up. I have put the 280x in my brothers computer and it boots up fine.

My Specs:

PC Part Picker

Click on names to find out more

MSI z68a g43 g3 with the latest BIOS update (5.2)

Intel Core i5 2500k

ASUS 280x

8gb Corsair Vengeance

OCZ Vertex 4 128gb

Antec EarthWatts 650w Bronze

Troubleshooting I did:

  1. I tried both PCIE slots multiple times.
  2. I put the 280x in my brothers computer and it posted and booted just fine.
  3. I tried my brothers 270x in my computer to see if it was the dual 6 pins having issues and it also booted up fine.
  4. I tried my brothers Lepa 500w in my system and it did not boot.
  5. Swapped in my old Sapphire 6850 (One 6 pin connector) and it posted and booted up perfectly.
  6. Cleared CMOS RAM.


  • The GPU is fine because it works on my brothers system.
  • The PSU is fine running single or dual 6 pins.
  • 6+2 pin might be faulty, but how can both of our PSUs have the same problem?
  • Something might be wrong with the motherboard or the PCIE slots.
  • Or, my system isn't getting enough power. I need someone to confirm this.

I am totally out of things to try and feel like ripping my hair out. What can you guys suggest for me to try? Much respect and love to you guys for trying to help.


I have solved this problem. The solution can be found in the following posts.

PSU is probably just fine. Check your BIOS settings for incompatible config (I think that's the problem, you probably have some parameter set so that it doesn't find the card). Otherwise, check PCIE slot (oxidized contacts, short-circuiting dust, misalignment, ...). If that doesn't help, your mobo has some kind of incompatibility, check the MSI support for that.

Are all the drivers correct?

It can't be the PCIE slot becasue two other cards are working fine. I'll check the BIOS settings. PCPartPicker reports that all the parts are compatible.

I solved it. Turns out my BIOS was not the latest. Updated to the latest and everything runs silky smooth!

Quite the rare occurance these days, should always have that at the top of the list of things to check when adding new major hardware :-)

Great that this is solved, then i can lock this thread.

grtz Angel ☺