Searxng and a vpn

so i have been playing about with searngx and while it does what it says on the tin,
its being a bit of a bear.
ive been trying to rout it behind the vpn but if i start the vpn first i get an error saying
cant assign an ipv-4 address in the default ip pool.

if i start the vpn after then try to search with searxng all the engines time out.
so basically it like the vpn is blocking searxng getting to the net.
i would have thought if it wasnt routing through the vpn it would just connect to the web via my normal ip via the eth0.

anyways im using the default docker_compose, and settings.

oh yeah and i tried reading the help docs. https://docs.searxng.org
not that helpful for my instance. that and the fact most of its reading like gibberish atm.
so some help would be cool if anyones willing to offer it.

  1. i dont know where the default docker pool is kept so i can add my vpn pool to it.
    or how to add my vpn pool to it.
  2. searxng has proxy settings. but as i said its tech gibberish rather than instructions.
    if your willing to decode the hieroglyphs into english, then thanks in advance.

How did you install it, Docker or standing up a Linux system and installing all the components?

oops… my bad. forgot… with a git clone from GitHub - searxng/searxng-docker: The docker-compose files for setting up a SearXNG instance with docker. into /usr/local/
so yeah docker instance.
running through docker compose.

there were no additional dependencies other than installing docker.io and docker-compose.
added a user to the docker and doing a sed -i to encrypt my instance key.

after that its just docker-compose up -d (-d make it a daemon)

other than the sed -i ive made no edits to the .env / docker-compose.yml / settings.yml files.

also running on xfrc kali so all the python dependencies were already installed.

there is something called morty. but im not sure it will be of use.

Ah, I’m a little out of my depth since Docker isn’t how I run things, and I set up Searx-nonNG. My first thought would be SearxNG/Docker isn’t configured to use the VPN’s interfaces correctly or is getting confused about which one the service is supposed to be running on and which it’s supposed to open outbound connections through.
My setup has it running on a standalone server which runs Searx/Filtron and then I have another server with the VPN client that runs a TinyProxy server where anything pointed to the proxy passes through the VPN. There’s a config option in Searx to tell it to use that proxy. It’s not the best solution, but it works. You don’t need Morty, it adds a proxy function so people can access websites through Searx instead of directly.
But yeah, I’d use… netstat? See what interface SearxNG thinks it’s binding to.

1 Like

thanks… gonna try the stand alone server install with apache or Nginx

yeah running into all sorts of issues with this…
in part because the instructions are hyrogliphs designed to put the average user off.
but also because half of the configs they tell me to edit dont exist on my system.

a docker json in particular is supposed to hold the default pools.
but as i said. even though i have docker installed and fully working. no json files other than key.json.
grrr…

i guess im starting from scratch again.
so will do a manual install of docker from the git and install all the reqs manually for searxng. :frowning: gonna be a long boring afternoon :frowning:

finally got an instance up and running.
dumped the docker install all together and just went with searx instead.
after a 4 day break i went back to it this morning and an hour later. all done.
i now have a python server running searx through my vpn :smiley:

pure pain in the ass. but im calling this a win. and a hard earned one :slight_smile:

I had numerous issues with searx after a while… The time outs were the last straw. I ended up jumping to whoogle and it’s been rock solid for months. Good to hear you got it working reliably

1 Like

so far its only google timing out >.<

i want this for osint as google just doesnt deliver.
but im always gonna be looking for alternatives so will look at whoogle.

2 Likes

well thats disappointing…
this search engine has a rather fatal flaw.

doing normal searches. fine no problem…
i use a google dork and within 2 searches i will normally get hit with a google capcha.
searx has no way of answering as the script is blocked from running (by design as it sends data to google).
as a result all searches become blocked.
doesnt matter what you type into the search bar you get a zero results answer.

so OOPS!. :laughing:
i guess i killed it.