Screen tearing in openSuSE

So I recently installed openSuSE on my second SSD and when I installed the catalyst drivers I noticed considerable screen tearing which is weird.
There was a little bit of screen tearing before I installed the drivers. I was hoping to counter that.
Any ideas what the problem could be?


Check this thread;



Thanks but it didn't really work. Also, it's quite odd that this happens on an AMD card, it's apparently known to be a Nvidia specific driver problem. (It's also worth mentioning that this doesn't happen on Ubuntu)
Any other suggestions?

What DE? Different environments use different compositing configs

I'm running openSuSE 13.2 KDE on a R9 290x. A quick update: The issue doesn't appear to be the propiertary AMD drivers. I removed them completely and I'm running the system on the open source drivers now, and I still got the same problem. Maybe KDE has a problem with the frame buffer but who knows. 
It's probably also worth mentioning that I only got screen tearing in that manner once before, and that was on Windows while playing Crysis 1 with V-Sync off in video playback.

Somewhere in the display settings > advanced-> enable full screen repaints should fix it, holla if not (not in KDE myself so my memory might play tricks on me)

Didn't fix it either. I got a feeling though that it doesn't actually use the OpenGL compositing type and therefore can't use Full scene repaints, although it says it does. Because every time I go back in the Desktop effects panel the compositing type is switched back to XRender, which is really strange....
I also tried to turn of Blur completely but didn't do anything, so back to the drawing board.... 

Hmm, do you have the mesa & vdpau packages installed? Those are needed for OpenGL

yes I do have both, I'll try to install the proprietary drivers again, maybe then I can select OpenGL

So that fixed it. For everyone who has the same problem: As stated above you need the Mesa and VDPAU packages, to enable OpenGL (otherwise it seems to run only in XRender which appears to cause the tearing) then you also need to download the proprietary drivers to, apparently, fully enable OpenGL for desktop use. (Here you find instructions for the proprietary drivers: I recommend the Build rpm yourself option) 

Once you got all that in place you can either force V-sync in the Catalyst driver (uses a bit more GPU resources) or go to Configure Desktop->Desktop Effects -> Advanced -> Compositing Type: OpenGL 3.1 (or the latest version) That should do the trick, if not, then just select in the OpenGL options right below Tearing Prevention: Full scene repaints

Hope this helps anyone who runs into the same issues.

Glad you got it fixed, but proprietary drivers aren't needed to enable OpenGL support, i'm guessing you were just missing some little dependancy, happens a lot lol

Yea that was my guess as well, I just wanted to write down a possible fix for anyone who might run into the same issues I had, thanks for your help btw