Screen tearing in desktop, seemingly all distros and DE's with nvidia 1060

OS currently being used in Manjaro on kernel 4.14 with KDE 5.13.2
Using a 1060 6GB with all distros and DE I’ve tried I get insane screen tearing even in the desktop, I don’t actually game or anything on Gnu/linux.

I’ve tried force full composite pipeline and full performance mode, all the usual fixes but none of them work. It’s so bad that I just use an old AMD card instead because the drivers seem to just work. No issue with the card in windows.
The arch wiki has also been tried (

Monitor is just a 1440p screen @ 60 hz so nothing crazy

I had same problem with an old Nvidia card. Same problem across several Distros. Just gave up on it.

Seems like I heard somewhere Nvidia cards generally work better in Linux though???

Yeah, not sure. My 1050ti seems to work fine. I need to manually set the 144Hz for the display and enable “force composite pipeline”, but after that it’s fine. Not great but fine.
That said, in KDE, my Worklaptop with integrated Intel feels more fluid than my Nvidia Rig at home so…

Have you made sure it’s acutally running at 60Hz? There are some sites on the internet to check that. Could be running at 59.9 something or 30Hz.

Edit: like this site

I also have a GTX 1060 6GB and am using Manjaro XFCE with Kernel 4.17. For me the force full composition pipeline fixed it however. What driver version are you using?

Have you tried using the nvidia-settings tool?

sudo nvidia-xconfig
sudo nvidia-settings

Select X Server Display Configuration

Change Resolution from “Auto Auto” to “2560x1440 60Hz”

Select Advanced

Check all three boxes

Click Apply

Wait for screen to refresh and accept settings.

Click Save to X Configuration File

If you still experience tearing or rippling, disable the “Force Full” box and try it again.

Use Chrome (or another browser besides Firefox) to text scroll capability. Use a windowed application to test the desktop.

I suggest this method if you’ve not tried it because the CLI/X.Org edit never works for me. This works every time (except on Solus).