Scanner not working

i have a brother printer/scanner DCP-195C, im using arch linux with kde so i have installed the drivers - cups sane print-manager skanlite and some drivers from the AUR - brother-dcp195c brscan3 brscan-skey. i have enabled the org.cups.cupsd.socket, brscan-skey service and saned.socket. and i am in the scanner group, the printer is working fine, but whenever i open skanlite it searches for the scanner as soon as it detects the scanner it closes throwing an error “opening the selected scanner failed”. but if i run skanlite in terminal as root it works. i want it to work as a normal user too so i don’t want to open a terminal everytime and run it as root.


as root run the “groups” command and see what groups root has access to. If there is no apparent group that makes sense, then you probably need to create a udev rule to give the scanner group access to that scanner in particular. You may need to add your users as an administrator in cups to manage the scanner as well.

Is the scanner directly connected to your PC or is it network attached?

i ran the command groups as root it only showed root as the group. how do i create the udev rule and give scanner group access to my scanner… the scanner is connected directly via usb.

I will leave that as an exercise for you. This may mostly be a trial and error thing. I would do a search for "udev rule for ".

Basically, some devices need to interact with certain parts of the system/kernel that they are only trusted to run under a root/sudo context. You can setup group access in a udev rule to give users/services belonging to a specific group, access. check the Arch wiki below.

thanx… i got it working i found a ubuntu forum page for scanner udev rules… i made a rule its working now for normal user

for anyone else looking for help -

1 Like

Thank you for following up with your solution! Welcome to GNU/Linux system administration!

1 Like

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.