SAS HDD's not showing up in Manjaro, worked before

Hey there, I need some help.
I am trying to setup a ZFS array for the first time and suddenly my drives have disappeared. I am running Manjaro 5.11.1-1, KDE Plasma. Drives are 4x 3TB HGST 7200rpm SAS 6gbps, connected to an LSI 9211-8i in IT mode. During startup, both the HBA and BIOS can see all 4 drives just fine. Manjaro can’t see them at all. I also have a Micron Zephyr 7100 800GB NVMe drive that does not appear as well, although that is lower priority and does not appear in BIOS. The catch is that all 5 of those drives showed up in Manjaro before. lsblk and gparted both showed 6 drives (boot SSD, NVMe, 4xHDD). Nothing changed with the setup, but when we went to setup the zpool lsblk would only list the boot drive. Haven’t been able to get them to show up since, even after hours of troubleshooting. I have tried putting the HBA’s PCIe slot to Gen2 as suggested by searching online, no effect. Manjaro install USB also doesn’t see 5/6 drives.

Rest of the system:
Intel Core i7-6950X
Thermaltake Water 3.0 Ultimate
2x8gb Corsair Dominator Platinum DDR4-3866 (running at 2666, not final RAM for the build, just what I had laying around)
LSI 9211-8i IT mode (Fujitsu branded)
4x 3TB HGST 7.2k SAS
Micron Zephyr 7100 800GB U.2 (on a riser card, U.2 cable comes in the mail tomorrow)
MSI GTX780 Lightning (laying around, needed GPU)
Fractal Design Define 7 XL
EVGA 850G3

Any help would be appreciated.


Double check it with a Windows install. But it is possible that you have suffered a critical hit to your CPU PCIe controller. Or the motherboard I suppose. Could be a complete loss of power from the PSU to the PCIe…

So if it isn’t software then it could be CPU, motherboard or PSU. You’ll have to check.

Set BIOS to default settings and they have all returned. Not sure what the problem was but if it comes back I shall return!

That was an X99 board? I wonder if you had a BCLK adjustment. I have a Gigabyte X99 board with a 5960X in it. The XMP on my RAM tried to set BCLK to 103 for some reason and my NVMe drives nearly ate themselves.

I could easily see a BCLK boost causing all the PCIe devices to fail.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.