Return to Level1Techs.com

Sapphire Nitro+ RX 480 8GB Amazon Scam?

amd
drivers

#1

Im hoping someone can tell me what ive stumbled upon right now. im going to do more testing including taking my motherboard out of my case but this is the story so far.

System specs first:
ASROCK Fatality mITX B350
Ryzen 5 1600 @ 3.8GHz
2x8GB GSKILL TridentZ 3000MHz
WD BLUE SSD 250GB
WD BLACK HDD 1TB
The offender: Sapphire Nitro+ RX480 8GB OC

So i found an RX 480 8GB Sapphire Nitro + on amazon for around 180 dollars. It was used so i expected atleast some sort of issues but i didnt expect this.

Upon installing the card in my system and attempting to clean install AMDs latest drivers my computer suddenly only recognized one monitor.

After 2 separate drivers (i believe Crimson 18.5.1 and 18.10.1) failing to work properly i checked the device in the control panel.

Windows recognizes a Radeon RX480 but reports to have “stopped the device” as its not working properly.

after uninstalling the drivers and installing the drivers that came on the CD it recognizes the GPU, the second monitor, and can play games very well.

However this poses a new issue, as the Radeon Crimson control panel now doesnt exist, meaning that i cannot change anything about the card, and cannot use Radeon ReLive.

After returning to amazon to see the sellers page, i get an Oops page from amazon saying that the sellers profile is now missing.

So i have a few questions:

–Do you think this card has been BIOS modded?(i did notice one of the screws on the backplate had been slightly worn as though it was taken off, and no warranty voiding stickers)
–Should i return the card to amazon and revert to using my old XFX HD7850 1GB?
–Or is this driver shenanigans a feature and not a bug on Sapphires part? (note, when i start my machine the old Red ASROCK BIOS logo is now instead a blue and white ASROCK|Sapphire logo.)

– PCIE LANE, EDIT: Tried my Radeon HD7850 and it works flawlessly latest drivers installed and card is recognized. Dont think its a Motherboard issue.


#2

Gpuz now has tools to check if its fake and bios info would recommend checking it out would help diagnose if its faked


my bad its only nvidia gpu’s at this moment sorry


#3

Should have mentioned, i checked out GPU-Z and the task managers new GPU portion.
GPU-Z has nothing out of the ordinary to report.
Task manager shows everything correctly as long as the CD drivers are installed. if any other driver is installed it wont show the GPU.


#4

Only things I can think of doing you have already done or thought of doing/asking about

sorry for my post bout gpuz I should read more about the features I am suggesting


#5

nbd, im grasping for any reason to keep the card at this point, its almost a 180 dollar disapointment.
Moving to doing testing outside of the case next.


#6

Amazon is pretty good about stuff like this they want you to spend that money


#7

I have inspected the heatsink when taking it out of the case and there appears to be some kind of black hairy dirt goo. Don’t want to disassemble it.


#8

Probably just carbon/fine dust from the fans, dust and some sort of gunk binding it. Not nice but probably nothing to worry about.


#9

So i decided that if the BIOS had been modded then i should check the first sensible place to look the bios modding tools(as nothing else can seem to report whats wrong).

Does this look off to anyone? i honestly dont know but VBIOS and BIOS Version dont match. I looked on tech powerup for my cards BIOS and it says my cards VBIOS is supposed to be what GPU-Z is reporting.
https://www.techpowerup.com/vgabios/187223/sapphire-rx480-8192-160921-1

Assuming this is the case, is it reasonably safe to attempt to replace the bios with the techpowerup bios?


#10

AFAIK Only works for Nvidia right now


#11

Back up the"original" and give it a shot.

Also don’t be afraid to disassemble the card, just get some good quality non-conductive (electrically) thermal paste to reapply, and possibly thermal pads too. A crappy application or old paste can really screw up heat transfer.


#12

Any clue if theres a way i can compare the contents of the files?
From what i can see the cards current bios is twice the size of the one TechPowerup has listed. i dont know if thats as as a result of pulling it off the card or because its actually modded.


#13

Could try to load the binaries into a diff tool.


#14

https://www.techpowerup.com/vgabios/188813/188813
Using windows Display adapter properties i found this to be the cards current bios.

Any clue what sort of tool i could use to read the binaries properly? I tried brackets but obviously thats not going to read them properly.


#15

VBinDiff should be able to do it.


#16


Thanks, At the end of the file i found a lot of extra space being used i presume for no reason as it seems to be just an extra long footer or something of the Maximum value in Hex.

The BIOS’s are definitely different, i dont know if thats because they just made up some bios to keep it going on the CD’s drivers but at this point im too far over my head.

At this point, im going to try it in another system before moving on to any bios modding. I did manage to use the mobile app to send the seller an email(even though i couldnt do it through the browser for some reason). They claimed they merely overclocked it as the “manufacturer guidelines” said to. And that they only used the card for VR. I doubt all of this and am going to get this resolved one way or another.


#17

An update: I tried it in another system and the same issue has occurred. After moving it back to my system the radeon crimson panel suddenly works but is at the 16.6 drivers however I still can’t use radeon ReLive.

At this point I’ve spent too much time troubleshooting a used card. I have school work to do so I’m going to hold off on any BIOS restoration as one of the most important features I desired has magically come to life( the ability to check temperature and clock speeds).

Thank you to mazeframe for showing me the binary reader and all who have given input.


#18

FIXED:
I Took it to an old APU system i have and threw a BIOS on from TechPowerup and it works and recognizes the 17.7 drivers!!!


#19

So how is the performance - like you expect from a RX 480? Then it was probably just bios modded for mining.


#20

Oh yes. And in some cases beating out the performance of other systems with the same card by about 5fps avg and 11fps high in Shadow of mordor.

However I returned the card because I opened it to clean it and to my surprise the die had 2 deep scratches and the heatsink had a deep gouge.

The seller not only mined with the card but opened it and abused it. And thanks to some research and contacting sapphire those cards don’t have warranty stickers on the screws so there’s no way to prove they opened it first.