Return to Level1Techs.com

Samsung 980 EVO strange/slow behavior

Specs: (running Windows 10 with latest updats)
ASROCK B560M Pro4
Ryzen 5 3600
16GB 3200 G.Skillz Ripsaw (2x8GB)
XFX Radeon 580 8GB
Bootdrive: Samsung 980 EVO 500GB (PCIe 4x 16GT/s - as stated in HWiNFO64)
Storage: Western Digital WD BLACK SN750 NVMe M.2 2280 1TB PCI-Express 3.0 x4
Additional Storage: 2x 3TB 7200rpm SATA 6GB/s HDDs

So all the benchmarks SEEM to look OK in CrystalDiskMark 8.0 for the 980 EVO (not exactly sure what they SHOULD be)

AND when I copy a multi-file folders to-and-from the WD I get reasonable numbers, I THINK (again I’m not sure what they are SUPPOSED to be) - This also goes for copying a SINGLE LARGE FILE to-and-from the WD

BUT when I copy a file FROM the Samsung back TO the Samsung the numbers are ATROCIOUS!

The temps on the drive are normal so I know it’s not thermal issues

And when using the additional rustys iron drives the perform as expected…
I’m not sure if this is typical behavior for the 980 to run between 400 and 500 MB/s when copying a file from one folder to another on itself, BUT it seems like the 6GB/s Samsung throws around is a bit misleading at this point.
Can someone tell me if this is normal, and if not if there is anything I can do about it?
Thanks :slight_smile:

Oh yea… added screen captures of the tests, and I put the upload code where I wanted the pics to be, but I’m not sure if it works that way… so if it does then you’ll see one of the pics has a VERY LOW transfer speed and THAT is from one folder on the 980 to another, the rest are between the 980 and the WD… and the CrystalDiskMArk and HWiNFO64 are for the 980 - :smiley:

Normal for the slow write speeds since you only have a single die and half the cache.

Cut the theoretical/published write speed in half for Zen 2/3 single die cpus like your 3600.

You only get full published write speed with the dual die cpus like the 3900X.

Thats for memory (RAM) not SSDs. I doubt he is saturating the write bw of the GMI link from CCD to IOD.

1 Like

You are correct. I was confused about the subject.

Definitely too slow. I have a PCIe 3.0 NVME drive that copies a movies file on the same SSD with about 850MB/s. Are you sure you have a Samsung 980 EVO? I tried to look into the specifications of the drive and can’t find it. I only find the 980 Pro and 980, no EVO drive :thinking:.

1 Like

oh crap yea it’s not EVO idk why I wrote that…yes it’s the 980 PRO - just like in the CrystalDiskInfo pic (the last one) - sorry
one of the those copying pics is FROM the WD drive back TO the WD drive and it’s pretty normal
ALSO, idk if I mentioned thi but the way that the 980 copies from itself to itself is very strange… it goes in short bursts about one second long - like if you were driving and kept pusing the gas then taking your foot off then pressing it 1 second later then taking your foot off… and it does this through the entire file copy…
I’m gonna boot into ubuntu and see if it happens there too, this way I’ll know if it’s windows or the hardware… i’ll post results shorty
OH YEA… I forgot to mention that my RAM doesnt want to at the 3200 it is rated for… i load the XMP profile and when reboot i get 3 beeps then it reboots, gives 3 beeps then hangs and I have to kill the power at the PSU… I have tried other speeds and can only get it about 3000 (i forget the exact number) It USED TO load the XMP just fine, but it has always done strange boot things like just not turning on the first time when i pressed power, but did on the second press… I’ve heard people mentioning ‘RAM TRAINING’ but I have no clue what this is… IDK if this is related (i dont think so) but I figured I would mention it… Oh and one other thing the on-board sound just stopped working one day out of the blue… it just doesnt put out ANY sound… so I had to get a PCIe Sound Card :man_shrugging: - I’m thinking of getting a new MoBo…
I’m gonna check Ubutu and post back what happens

WELL… I went into Ubuntu Studio (the newest version as of 2 months ago) and NONE of the copy/paste transfers I tried ran properly - they were ALL between 200 and 300 MB/s :man_shrugging: That incluses from one SSD to the other and from itself back to intself - both of them - they ALL were this slow… So I figured it has to do with a driver/setting not installed or something, which I wasn’t about to go down that rabbit hole right now - I was running off of a USB stick as a LIVE session, so I figured this proved nothing…
SO I then booted into Hiren’s Boot CD from USB and got identical results as if I were running more normal install of windows 10…
BUT I tried a couple of the HDD Diagnostic apps on HBCD and while I was waiting for the test to finish I thought of something… the SDamsung SSD is the ONLY thing on my computer that is running in PCIe Gen 4 … my video card is a 580 and that doesn’t run in Gen 4, and the secondary M.2 slot is Gen 3 (I’m not sure if that SSD is even Gen 4 anyway… I really don’t think so) …
Soooooo I’m gonna do some BIOS settings tweeak and try to turn it down to either Gen 3 or take it from the 8x (i’m guessing) it’s running at to probably 4x (or lower than whatever it’s set at)
Keep ya posted :slight_smile:

so i disabled a couple of settings that had to do with the Resizable BAR (which I have zero use for currently) but DIDN’T change any of the Gen3/4 or 16x/8x/etc settings YET
but I got some strange results…
So the copy/pastes that involve the WD drive all remained the same general speed BUT the ‘copy TO iostelf FROM itself’ has gone from 200 - 300 MB/s to now 700 - 900 MB/s … :man_shrugging: - but this is is not rigth lol
This HAS to be a setting in the BIOS causing all of this… It IS the Mobo!! I KNEW I should have just returned it for my money back the moment the soundcard died… but I didn’t want to be with ANY computer for a few weeks… this was a BAD DECISION :face_with_symbols_over_mouth: Oh well… spilled milk and such… this was all back in November of 2020 right before prices went insane and now even my MoBo has gone up from 85 to to 125 … stupid inflation lol -
I’m gonna go mess with those other settings

OK, NOW I FEEL LIKLE AN IDIOT! :man_facepalming::man_facepalming::man_facepalming::man_facepalming::man_facepalming::man_facepalming::man_facepalming:
After going through my BIOS/UEFI and changing EVERYTHING that had to do with PCIe and the NVMe setting I made ZERO PROGRESS other than the small change that I wrote about earlier…
So I browsed a few places after searching Duckie for ‘980 Pro slow’ and came across something I was unaware of: Samsung Magician
This is their software for their SSDs - I had NO CLUE this existed… mainly because I DIDN’T go through EVERY SINGLE PIECE OF PAPER that came with my drive (there was a little fold out paper that was honestly in between the pages of the Turkish language pages of the drives manual LOL) and on this was a link to this software
And so Samsung Magician has the ability to Benchmark all your drives, run some basic diag tests, and (MOST IMPOTANTLY) update your FIRMWARE (:man_facepalming:) and run some Windows feature I never heard of called OPTIMIZE DRIVES (:man_shrugging:)
I’m guessing you know where I’m going with this lol … Hell I’m so old school I didn’t even think about a drive needing a firmware update. These updates have gotten out of hand… it’s impossible to keep track of EVERY SINGLE DEVICE that needs to have a firmware update… IT’S ABSURD!!! For example, the other day I was getting into my Model S (of course I expect i t from Tesla tho) and on my phone I got a notification I had never seen before. It was from my car!! WHAAA?! Why wouldn’t the car just display it on the screen? So I open the notifications on my PHONE and my CAR is telling me that I CAN’T LEAVE until I do a FIRMWARE UPDATE… FOR MY TOILET!!! IT say’s it was unable to flush because of an outdated firmware and this causes not only a health hazard to the occupants of my home but a possible risk of AN EXPLOSION from BUILT UP FLAMMABLE GASES from NOT FLUSHING the toilet!! And it it said this is only possible because of the BEAN BURRITO I had FOR LUNCH THE DAY BEFORE!!! IT said something about there being an extra build-up of methane or something. So I had to go inside, wire my phone to my toilet, wait for the update to finish, make sure it flushed and cleared all of the safety hazard warnings, and THEN I got back in my car. The strangest part of all of this is when I got back in my car and pressed the start button a little floating head of Elon Musk popped up on my Media screen and he said 'Thank You" and just dissappeared WHILE PLAYING A FART SOUND!!! - HAS THE WORLD GONE MAD?!
:wink:
Anyway, so I did a copy/paste of the same 18GB file FROM the 980 back TO the 980 and it was at about 1.5GB/s now… FINALLY!! IT sure isn’t the 7GB/s I was led to believe it would do, but I don’t think that was MegaBYTES they were showing…
Thank you for taking the time to read my little struggle here. And I hope you enjoyed my firware story :slight_smile:
See ya round!!

The 980 Pro is rated with 5000MB/s SLC-Cached (1100MB/s TLC) in sequential writes only. The SLC-cache is 4-18GB in size depending on internal magic, which is also the size of the file you test with. When you copy on the same disk it has to read from the disk before writing again, which will have a performance impact. Also I see in your screenshots the drive is quite filled and I do not know what percentage filled the specification is based on. If you want a good benchmark of your SSD, benchmark it when it is not almost filled and then copy from a ramdisk instead.