Return to Level1Techs.com

Ryzen crashing while idle

I’m running Manjaro and Windows 10 with a Ryzen 7 3700X, an MSI 7b78, a RX 5700 XT, and 32GB of G.SKILL Ripjaws V Series PC4-25600 3200MHz (F4-3200C16D-32GVK). I’ve been having random reboots when while idle on both Linux and Windows ever since I setup the computer and none of the solutions online seem to work at all. I’ve updated the bios, disabled the c-states in both the bios and Grub, changed the power settings to typical, disabled XMP, run memtest, reseated the CPU, I even bought new RAM. Nothing seems to be working. Best I’ve managed to do is get it to happen less often, although I’m not sure why. Any help or suggestions would be appreciated. Here’s the error it’s giving me, btw:

– Logs begin at Fri 2020-09-04 02:48:30 EDT, end at Wed 2020-10-21 03:22:10 EDT. –
Oct 21 03:21:30 Compy-3700X kernel: mce: [Hardware Error]: CPU 2: Machine Check: 0 Bank 5: bea0000000000108
Oct 21 03:21:30 Compy-3700X kernel: mce: [Hardware Error]: TSC 0 ADDR 1ffffbbe2e50c MISC d012000100000000 SYND 4d000000 IPID 500b000000000
Oct 21 03:21:30 Compy-3700X kernel: mce: [Hardware Error]: PROCESSOR 2:870f10 TIME 1603264884 SOCKET 0 APIC 4 microcode 8701021
Oct 21 03:21:30 Compy-3700X kernel: mce: [Hardware Error]: CPU 4: Machine Check: 0 Bank 5: bea0000000000108
Oct 21 03:21:30 Compy-3700X kernel: mce: [Hardware Error]: TSC 0 ADDR 1ffffc0bdca7e MISC d012000100000000 SYND 4d000000 IPID 500b000000000
Oct 21 03:21:30 Compy-3700X kernel: mce: [Hardware Error]: PROCESSOR 2:870f10 TIME 1603264884 SOCKET 0 APIC 8 microcode 8701021

1 Like

What I’d try then is trying a positive voltage offset, starting very low like +0.05 and seeing if that helps the stability. If that doesen’t work upping the voltage up to +0.1 in small increments I’d try to work on the SoC voltage in the smallest increment possible up to 1.15V just to be safe. Don’t up the positive offset and the SoC at the same time. If the positive offset doesen’t work reset to default and up the SoC.
I’d also check if the BIOS is up to date, just in case there have been some improvements to stability.

Something like this?

Yes, that’s the setting for the SoC voltage. Be EXTREMELY careful with it because the upper safe limit is 1.2V but I won’t go there myself. Use very small increments and see if the crashing situation improves. I wouldn’t up it 0.05V right away.

1 Like

I dropped it down to the lowest setting for now. I didn’t really think about the voltage it was already running at, but I see what you mean now.

Now that I’m looking better at the pics you posted, what you can also try if the positive offset doesen’t fix the issue is to lower it down of just one increment because I’m seeing that your PC is already running 1.112V.

But yeah, you picked up my suggestion very well. I hope it helps. As always be careful. I don’t mean to worry you too much but messing with voltages going up can be dangerous.

check your bios for an option like

“PSU Idle Current”
“typical” or “low”

it could be set on low – you want typical.

Ryzen uses so little power that some powersupplies get super weird at the very low power draw. This type of crashing is also associated with that situation.

HI @Gandhi, I was having similar issues with a gigabyte x570 & 3700x. One thing that stabilized it a bit better was to change the cpu core voltage from [auto] to [normal]

I have xmp enabled with ram set to 3200mhz - that is it. (The ram defaulted to 2166 eventhough it is 3200, thats a first. Gotta love AMD)

If this is not present, turn off the C6 C-state using zenstates.py:

This is also available for Windows. Linux ignores BIOS settings for C-states like C6 on Ryzen and that’s why you still need zenstates.

1 Like

@Gandhi - I jsut looked and set to [normal] I’m running at 1.22v only

@wendell I already have it set to typical. Not totally sure if it made a difference, but that alone didn’t outright stop it.

@kungr I haven’t tried this yet. I’ve tried disabled XMP and running the cpu with MSI’s ‘game mode’ turned off but neither made a difference so I just left them on for now. I’m trying MetalizeYourBrain’s suggestion atm, but if that doesn’t work I’ll try this.

@FurryJackman I already have it disabled in the bios. Does it matter? I tried using zenstates.py before, but it didn’t seem to make a difference, though I may have done it wrong.

@kungr The extra voltage is probably from the ‘game mode’ setting I mentioned. It’s basically a built in overclocking utility. Disabling it didn’t seem to make a difference so I left it on, however I haven’t tried it with the [normal] setting.

Yeah, zenstates was the only way to turn off C6 C-state on Ryzen AFAIK on Linux. There are extra instructions where I linked. Using Grub arguments made no difference specifically on Ryzen.

So… it hasn’t crashed in several days now. I’m EXTREMELY hesitant to say that it’s fixed, but so far things are looking good. On a hunch I reset everything to default and did not re-enable the auto-overclocking feature despite this it seemingly not making a difference before. The only changes I’ve made are enabling XMP and changing the PSU Idle Current from ‘Auto’ to ‘Typical’.

LOL, nevermind! I just wrote how great things were going, only for it to crash an hour later! sigh @FurryJackman How do I setup Zenstates?

If you don’t try booting with processor.max_cstate=5 rcu_nocbs=0-11 That seemed to help me in the past

I add that to grub, right? Would I place it in “GRUB_CMDLINE_LINUX_DEFAULT” or “GRUB_CMDLINE_LINUX”?

Did you botch the cpu paste with your fan installation?

There is an emergency shutdown temp setting on the fan manager page. if it is set to 75-80 (to low) it might just panic and shut down.

There’s a Github repo here with the files and instructions you need:

Make sure to add python3 before the zenstates.py references as by default some distros don’t know which python interpreter to use.

Also trust me when I’ve tried Grub arguments in the past to have it be ineffective. Ryzen needs you to modify the MSRs to disable C6 in Linux.

I have no experience with it, but Zenstates is also available for Windows, but should work similarly.

@kungr I don’t think I so. I’ll check the bios, but I think if I’d done that it’d be crashing under games too, not just while idle.

@FurryJackman Ok, I’ll try this. The one I used before wasn’t setup with systemd, so maybe that’ll make a difference.