Return to Level1Techs.com

Ryzen 2500U, Installing Ubuntu, Blank Screen


#1

Trying to install Ubuntu 18 on an ideapad 530S (ryzen 2500U, vega 8)
-Boots from USB
-Presents option to install ubuntu
-After pressing enter just a blank screen, screen is still on its just blank.

I have tried disabling secure boot, amd platform secure processor, booting in legacy…
I have tried ubuntu 18.04.1 and pop_os 18.04.

Should I be trying arch or fedora?


#2

Trying fedora I got this;


#3

Looks like it might be an issue with virtualization? Is that enabled, and is this a 300 series board? Did you run update on the eufi?


#4

-Emm… this is a laptop a Lenovo ideapad 530S-14ARR.

-Tried both enabled and disabled

-Yes bios is updated to the latest version

One thing of note, when I opened the laptop, I noticed that it was using Samsung M471A5244CB0-CTD memory, which is 2666MHz 4GBx2. Ryzen 2X00Us are only rated for 2400. And Win10 runs fine.


#5

Also WTF is this, never seen this before…


#6

That shit’s new to me too. not sure it matters.

Have you tried the “try ubuntu” option and installed from there?


#7

Yep, try ubuntu and try pop_os and all options in fedora…


#8

I believe this is the Windows OS license. It is tied to the motherboard now. So if you ever want to install windows 10 again you would just need the iso.


#9

Yeah, you’re not the only one having issues installing on newer lenovo laptops.

Give this post a shot
https://evilazrael.de/node/401

You need to set some boot options in grub.


#10

Upon inspection of the box the laptop came in, I realized how serious my problem is…

For those that don’t know, here a documentary on Bratislava:

jk :smiley:


#11

Unfortunately this is extremely common with Ryzen Mobile.

You have to add the kernel parameter pci=noacpi to boot into the live image, regardless of distro.


#12

Excellent, how do I change kernel parameters of a bootable usb? Is that in the grub.cfg? I use nano to edit .cfg? Where do I put the parameter? Does this look right?


->


#14

It’s pci=noacpi and it’s supposed to be before the dashes, one space after “splash”.


#15

Like this? Do I need the dashes?

Also I cannot write even with sudo nano?


#16

This is usually much easier, boot from the stick and in the grub menu select the entry and press e, there you can edit the parameters for the next boot.

Edit: and you should add the additional parameters to the linux line, not on the initrd line.


#17

Ok this is as far as I got, what now?


#18

No idea, I am not a grub expert. But if the menu you defined is not showed, something is really wrong.

Try ubuntu again. When in the boot menu, choose “try” or install and press e. Read the text below the selection box, maybe the edit hot key is a different one.


#19

Thanks for the help everyone, I am taking a break and I’ll get back to you on that (maybe in a month).

…But yeah this situation is looking really fucked


#20

You selected to go to a minimal bash and not edit the boot entry.

Select the entry, press the key to edit the boot option, put the text at the end of the kernel (linux) entry and not the initrd