Ryzen 2 (3000) doesn't boost to its rated max boost clocks. Der8auer approved

so you need to set the boot memory voltage to 1.35. I had that too. After that it was at least stable booting again. You will need to load optimized defaults, then set the boot memory voltage.

1 Like

I cleared the bios and started from scratch. So far so stable. I literally don’t know why they released the same bios twice.

That one has some bug fixes. Also if you tweak memory timings don’t bother use ryzen master instead. Ui seems bugged.

1 Like

The seriously need to release fixes for the voltages. So stock isn’t so bloody high. Also,

with stock setting and manual voltage change. presents that kind of FPS for rick and morty encoding. With my 2700x I got like 35ish.

1 Like

yeah, crazy aint it? If my experience with my ch8 is to be believed, you’ll see about a 3% uplift in multicore and 5-10% uplift in 2-4 core perf once they fix the thing.

1 Like

Have you ever tried handbrake benching with you gigabyte board? I would like to know if your 4.5ghz is stable in handbrake. I have never been able to overclock and have it stable in handbrake even if it is stable in prime95/aida64. It is just the specific work load of transcoding that crashes. I have found I can disable one thread in affinity and it is stable.

This was my youtube comment on agesa/bios regression:
”I reflashed my MSI x570 Carbon to 1002 after a week on 1003a because I could not match my initial quick tests done just after building the system before flashing to the latest bios… I get better Single core boost with 1002, multi about the same, perhaps a bit more stable clocks. Now looking closer in RM at the 1002 results - why is there such a difference in reported PPT and TDC load? https://imgur.com/a/JORbZCb labeled cb runs on 1002 and 1003a. https://i.imgur.com/QuVOgUK.png some results on 1003a ”

After looking at my CPU-Z validations it seems cpuz reports both bios as agesa 1003.


So now I’m not at all sure if it’s agesa or just msi bios…

1 Like

Not sure how much is the agesa or how much is Asrock, but I’ve encrountered a mixed bag with the taichi x470 and the 3900x.

was running a 2600x on this board, with 2x8GB gskill 3200 RAM. RAM ran at 3200 just fine, just let xfr and pb do its thing.
eventually updated bios to 3.4 because of future purchase of 3900x

fast forward to ryzen 3000 launch, and got a 3900x on launch day, woot!
swapped it onto the mobo, strapped on a noctua nh-d15
clocks on chiplett 1 boost up to 4.6 - 4.65 on various cores at various times, just like they should.
clocks on chiplett 2 boost up to 4.35 and the very rare occassional 4.4 at various times.

AMD putting binned 6c chipletts in with regular ones to keep pricepoint reasonable?

anyway, the issue I ran into at this point with bios 3.4, is that the IF would not go above 2400 with the 3900x when I turned an xmp profile on. It worked with the 2600x flawlessly, with 3900x it did not work. further reading from around the web says others have same issue with same board.
on 7/25, asrock published bios 3.5 with agesa, don’t know if this contains revision AB or what.
Went home and updated the bios to 3.5 which went smoothly and the IF issue is now fixed.
BUT now the max boost clocks no longer work the same as with bios3.4. max boost clocks across the board, whether single or multi-core have went down by about 100 - 150Mhz. for example, when I was getting 4.65, now the max is 4.5. Idle clocks are much higher, and it doesn’t matter what Ryzen power plan I choose.

I chose this mobo because it has some beefy VRM’s and can handle power for the 3900x with no issues, just had no idea that bios would be thsi buggy from one version to the next, stupid asrock not allowing bios rollback.
Whether bios 3.4 or 3.5, games and apps run just fine, it’s that this small clock perf regression is slightly annoying. hopefully asrock/amd gets thsi figured sometime soon, oh the first world problems! ha

1 Like

If monster cooling is liquid nitrogen and this is a no go for day to day use.

1 Like

So I got things dialed way more in since this post and at 1.38v things are more reasonable. One ccx can be 4.5 and the other ccx can be 4.3 and it’s fine at 1.35v. basically. 3533memclk tho.

Boosting behaves properly for me if I keep memclk at ,3533 and fclck at half that

1 Like

new upate:
sometimes I am “really late to the party” and it turns out that with the x470 taichi, once you upgrade to a bios that supports ryzen 3000 series, you can not roll it back to a bios that does not support ryzen 3000. So I was able to roll it back from bios 3.5 to 3.4 successfully.
And much to my surprise not only are the clock speeds back to what they are supposed to be, now the IF issue is fixed as well! All I did was flash the bios and at left everything at default settings. Then set xmp profile to 2800(the limit before was 2400) and the mc, IF and RAM were all at 1400!
But as it also turns out, something about my setup - most likely the RAM itself - can’t run stable past xmp 2866. I can go up one tier higher, boot into windows and Ryzen master will show IF matching RAM speed, but launching anythign else will cause memory error. I’m sure someone experienced with manually tuning RAM timings can get the RAM to 3200, or even higher, but I honestly don’t have the time to sink into eeking out an extra 2 or 300 Mhz.