Return to Level1Techs.com

RX590 Ubuntu 18.04 Setup Guide

#22

GREAT tip on removing irqbalance! Gonna try that out on my Ubuntu installs.

An alternative to the GNOME shell addon cpufreq is to manually force the governor to performance all the time. I made a thread on that:

0 Likes

#23

I’m trying to replicate this with an ASUS ROG Vega 64 and Benq EX3203R) but I still can’t see my monitor refresh rate fluctuating on any game (Currently testing on Rocket League via Steam). Could You do a step by step guide how to get FreeSync working on kernel 5.0 and PADOKA PPA drivers (mesa 19.1)? I’m surely missing something here but I don’t know what.

0 Likes

#24

Hey Wendell, will this apply for a Manjaro build?

0 Likes

#25

Hey i just got a Saphire RX 590 Nitro as a replacement for my old Nvidia GPU. I have installed Kubuntu 19.04 (Beta) right now with Kernel 4.20.10 and Mesa 18.3.4 . The GPU worked out of the box with no workaround needed.
I have used the regular kubuntu releases as my daily driver for years. I guess using this versions is a good thing if you rely on more up to date opensource driver support. As it looks everything seems to be right in place for the RX 590 by April 2019. I can confirm that even Freesync works out of the box without the need of any configuration. The only thing that does not work is the zerofan mode of the card. So the fans are always on in a low rpm mode.

0 Likes

#26

Thanks a lot, this helped me after days struggling with my Xubuntu/Ubuntu Mate distros and the RX 590.

1 Like

#27

Does anyone know if AMDGPU power state issues are still a thing with this card?

I had a lot of trouble in the past with my R9 390 and have had to run with the following kernel parameters

amdgpu.dc=1 radeon.cik_support=0 amdgpu.cik_support=1

amdgpu.dpm had to be completely removed to get my PC to boot.

I’ve just bought a Sapphire Nitro+ RX 590 (in black “cos Wendell says 'black is the new black” :D)

I haven’t changed any of the old kernel parameters yet (the old cik_support params can probably be removed now) and everything seemed to be working fine. I did a couple of runs of the UNIGINE Heaven to see if there were any problems when the GPU is under load and everything ran ok, but then I got a little adventurous and decided to change from the default settings to “Ultra” … and the GPU crashed.

The crash was pretty much the same as when there were issues with my R9 390, the screen goes black and the monitor turns off (in this case the GPU fans turned off too)

I found the following in the journal log:

Mar 12 17:41:20 red-dwarf kernel: pcieport 0000:00:03.0: AER: Multiple Uncorrected (Fatal) error received: 0000:00:03.0
Mar 12 17:41:20 red-dwarf kernel: pcieport 0000:00:03.0: PCIe Bus Error: severity=Uncorrected (Fatal), type=Transaction Layer, (Receiver ID)
Mar 12 17:41:20 red-dwarf kernel: pcieport 0000:00:03.0:   device [8086:6f08] error status/mask=00040000/00000000
Mar 12 17:41:20 red-dwarf kernel: pcieport 0000:00:03.0:    [18] MalfTLP                (First)
Mar 12 17:41:20 red-dwarf kernel: pcieport 0000:00:03.0:   TLP Header: 20001000 010022ff 0000000a 10682040
Mar 12 17:41:21 red-dwarf kernel: [drm] Fence fallback timer expired on ring gfx
Mar 12 17:41:21 red-dwarf kernel: pcieport 0000:00:03.0: Root Port link has been reset
Mar 12 17:41:21 red-dwarf kernel: pcieport 0000:00:03.0: AER: Device recovery failed
Mar 12 17:41:23 red-dwarf kernel: amdgpu: [powerplay] 
                                   last message was failed ret is 65535
Mar 12 17:41:23 red-dwarf kernel: amdgpu: [powerplay] 
                                   failed to send message 282 ret is 65535 
Mar 12 17:41:31 red-dwarf kernel: [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring sdma0 timeout, signaled seq=193836, emitted seq=193838
Mar 12 17:41:31 red-dwarf kernel: [drm] GPU recovery disabled.
Mar 12 17:41:31 red-dwarf kernel: [drm:drm_atomic_helper_wait_for_flip_done [drm_kms_helper]] *ERROR* [CRTC:44:crtc-0] flip_done timed out
Mar 12 17:41:31 red-dwarf kernel: [drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring gfx timeout, signaled seq=66210, emitted seq=199236
Mar 12 17:41:31 red-dwarf kernel: [drm] GPU recovery disabled.
Mar 12 17:41:33 red-dwarf kernel: amdgpu: [powerplay] 
                                   last message was failed ret is 65535

It looks like it’s the AMDGPU driver is trying to change the power state and something goes wrong.

Should I be using the amdgpu.dpm=1 kernel parameter with this card?

*EDIT: Forgot to mention, I am on Fedora 29 with kernel 4.20.14

Thanks.

0 Likes

#28

So, did anything change with requiring strictly 4.20.0 or can you use a newer kernel now that things have settled down?

Do you still need to nomodeset on 18.04.2’s 4.18 kernel?

0 Likes

#29

Yes, 18.04.2 doesn’t work with the rx590 without nomodeset.

2 Likes

#30

I am using kernel 5.0.1 with 18.10, works good so far. I haven’t gotten to the pass through to windows yet, still sorting out the raid 10 setup.

0 Likes

#31

Yeah i’m kinda currious what Cannonical is going to do with it.
Maybe they are gonne pick this up.
Because to get newer amd cards to work properly is still kinda a pain.

0 Likes

#32

My curiosity was more with if a newer 4.20 release or the 5.0 release solves the problems Wendell mentioned with Kernels newer than 4.20.0 using UKUU.

0 Likes

#33

The new Ubuntu Beta 19.04 Disco Dingo will soon be released.
So i guess we will know soon.
It is already available for download comes with kernel 5.0.0.7.

0 Likes

#34

I am allready running Kubuntu 19.04 on my Rig with the Sapphire RX 590 Nitro. Everything worked out of the box for me. I added this ppa https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers to get MESA 19.1 running on the system. Compared to my userexperience made with my now defective Geforce 1060 GPU i have noticed the following pros and cons with the RX 590.

Pros:

  1. Easier driversetup and maintenance

  2. Screentearing in KDE Plasma is gone without any configuration or workaround.

  3. Better performance in native Linuxgames

  4. OpenGL Acceleration works now in KDENLIVE and Libreoffice

Cons:

  1. Fancontrol does not work correctly. Zero Fan Mode does not work. In some games the fans are very loud even with a measured gputemperature at 55°C. In other games the card stays relatively silent while the gpu is reaching a temperature over 70°C.

  2. Lesser performance (stuttering) in games played via proton when dxvk and vulkan are utilized for directx 10 or 11 titels.

I am still unsure about freesync. The OSD of my AOC Screen says that freesync is activated but i still get tearing in some games so i have to use vsync there to get rid of it.

0 Likes

#35

I wonder if the RX590 is now supported ‘out of the box’ with Ubuntu 19.04?

0 Likes

#36

Anyone having issues with gnome-shell and the lock screen? When coming out of lock on Fedoraa 29, 30b, and OpenSUSE Tumbleweed I have to restart gnome-shell to clear out the “slowness” or “lagginess” that comes up. This was not the case prior to using the 590. I have not tried gnome on Ubuntu as of yet.

0 Likes