Return to Level1Techs.com

RX 5700 XT Ubuntu screen tearing

Hi All,
I am having a problem when playing videos on Ubuntu 19.04 there is a lot of screen tearing happening with the RX 5700 XT. I am a user of Linux not student of Linux so my problem solving is done by the duck duck but this time no luck luck.
Any help most welcomed.
Cheers hairy.

in/etc/X11/xorg.conf.d there should be a file named xx-amdgpu.conf or something.
add the lines:

Section "Device"
    Identifier "AMD"
    Driver "amdgpu"
    Option "TearFree" "on"
EndSection

I had the same problem, i followed
https://wiki.archlinux.org/index.php/AMDGPU#Xorg_configuration

For me, it worked. But the outcome does not feels smooth :frowning:
Still a start :slight_smile:

I like to revoke my answer above since this solution seems to have drawbacks. I worked many hours through the night and made several observations:
When you modify the xx-amdgpu.conf as stated above the screen will stop tearing. However: the graphics become jerky somehow. The window movements are not smooth anymore. The weird thing is that it only affects the monitor that is “touched” by the mouse.
So if you have a window (just a plain console windows for example) and place it over the border between 2 screens, you can start moving the window up and down.
Depending where (on which monitor) you grab the window bar, that part of the window stutters a lot, the other monitor (where there is no mouse)) runs smooth. I really mean the stuttering, just ignore that the monitors sync at different times, so one monitor lags the other, it is really about the jerkiness on the monitor that hosts the mouse.

It is as if the mouse cursor drawing is synced additionally to any other syncing so that you get a mix of 60Hz / 30Hz Vsync. Absolutely awful.

As of yet i do not know how to solve that. I am not sure how to google it since the problem is hard to describe in the first place.

Having xx-amdgpu.conf unmodifed and tuning on any Vsync option for the compositor (in Mint under System Settings -> General) does actually introduce some sync-behavior, however the tearing line is just somewhere on the screen. In some sense it actually frequency locks correctly, but the sync is out of phase with the monitor. Bullshit!

I think this sync mismatch is in part responsible for the bad experience when Option "TearFree" "on" since it is additionally phase syncing the already frequency synced window content which introduces random delay. Add in the mouse drawing sync issue and you have a perfect stuttering system which is annoying as f.

ANY other input, is appreciated, i guess.
Also just replicating the above behavior would already help so we can learn if this is hardware related for simply a software architecture problem.

I am on Linux Mint 19.2 Cinnamon. Kernel 5.0.24 (the one that works with amdgpu-pro)

Edit: i just realized you are on Ubuntu. I originally answered because Mint is based on Ubuntu and should share the same solution, however the window-compositor syncing issue might be Mint-specific. But it would be nice if anyone tries to reproduce the behavior independent of the distribution.

Hi all,
I have given up the fight with Ubuntu and moved over to Fedora, I can report than up until now I am problem free.
With Ubuntu even upgrading to 19.10 didn’t improve things I couldn’t even set the screen refresh rate to 60 from 30.

Thank you to all that took time to comment and maybe keep it going for others.

Cheers,
hairy.

1 Like

I use Fedora also, do you use “tear free” with it or the stock X11 (or Wayland?) configuration?