Return to Level1Techs.com

Rust: Disconnected EAC - EAC Disconnected

Been wanting to play Rust for a year and a half now and finally got it. Apparently EAC is a piece of shit though and I’m not sure what I’m supposed to do.

When I try to connect to a server I get kicked automatically with the above error or something similar related to EAC. In windows you can delete the EAC files and call it good but thats not a thing in linux.

I also get this blob of something on upstart of the game.

When I went to go find the lib on the archwiki some dumbfuck deleted it like a year ago and no one has been able to upload it. I’m not really sure what to do, all I want to do is play my new game.

Just helped someone else fixing the issue on Linux

Try connecting speakers instead of headset and relaunch (Yes, it’s weird)
Other fix is, gaming with headset is giving more permissions to the Steam /Temp folder which can be done through Terminal by issuing the command chmod (Insert preffered chmod here) onto username/Home/.steam/steam/steamapps/temp

Hope it helps.

I don’t really know what headphones would have to do with it. What chmod was used?

Just try it out and see for yourself, that way you may be more able to come up with a better solution. I dont have rust, so i cant.

The chmod mod command used was chmod 777 , maybe chmod 755 may also work. Im just getting to learn more about chmod myself

well the chmod didn’t work for future not of anyone else.

Tried with settings sound to speaker mode and relaunch?
this actually fixed the issue for many. By setting it at launch and changing it back ingame.

Yeah that doesn’t do anything dude. Its an EAC bug, you can see it in the picture I posted.

You could try a chmod command on the x86_64 folder

I just had to fix this myself the other day…
Set your launch options to this:
LD_LIBRARY_PATH=/usr/lib/openssl-1.0-compat/ %command%
and grab libopenssl-1.0-compat from the AUR (it keeps git of deleted pkgs):
git clone https://aur.archlinux.org/libopenssl-1.0-compat.git

If that link ever goes down, I have a built version here: https://drive.google.com/open?id=0B1Xm28Jmwn1AV2pVT1hhekwwWkk

This actually happened in the latest Rust update and I’m sure it’ll be fixed when the next one comes out, which is tommorow (no guarantees)

2 Likes

thank fuck lets hope this works.

Well I put in your stuff and tried and it didn’t connect, so I rebooted because maybe idk and it still gave me the error at startup.

I’m not confident at this point.

No it didn’t work.

Did you clone the package from git and makepkg in the directory?

Well I’m not new to arch :stuck_out_tongue:

Just wanted to make sure.
I guess I’m not sure then how if you did all that, because I did exactly that and it’s working great for me.
OHH, I forgot to mention, @Aremis, remove “no-ssl3-method” from ./Configure in the PKGBUILD.

I’m gunna fucking kill myself

Thats like the half of the errors I don’t understand.

Well try what I mentioned above and see if it actually works then. Sorry about not mentioning it first time.

You meant remove the line right?

Just the text.

I’m just going to grab your package instead :expressionless:

That works I guess.
Here’s what the PKGBUILD should look like btw: https://hastebin.com/azifajozid.bash