Return to Level1Techs.com

Running Windows games with GameGuard

Since I changed my OS to linux I stopped playing a MMORPG Metin2 mainly because of the OS change but also because I spent way too much time playing it.

Now I would like to get back into it, tried installing it with the latest version of wine, the installation went fine, was able to apply all patches and update the game.

When I turn on the game GameGuard is called and returns an error

Please kill all conflict programs and restart the game.

After some research I found out that GameGuard does not let the game run under wine.

I am interested in finding a solution that does not include dual-booting.
Any of you guys can run games that use GameGuard under linux?

Thanks in advance.

PS:
https://appdb.winehq.org/objectManager.php?sClass=version&iId=7198

Due the nature of GameGuard being a rootkit that install two virtual drivers that need be ran at ring 0, it currently cannot run at Wine.

To play a GameGuard bundled game please try VirtualBox instead.

The problem with VirtualBox is that it can not access the GPU directly, which is necessary for 3D games, isn't that correct?

You don't need GPU passthrough for all 3D games, it just makes it faster. Depending on the hardware all you should need to run Metin2 via VirtualBox is to enable 3D acceleration via VirtualBox Guest Extensions. It also helps to turn off Windows Aero and all similar features on the VM.

I had windows 7 installed when I was playing and it ran OK but with some hickups when there were many objects on screen. Is it going to be playable on the virtual machine?

I know the best way to know is to try it, but based on your experience what should I expect?

I've seen Metin 2 (7 years ago) run on computers that would be 10+ years old. I wouldn't expect the highest settings, but I think you'll be fine with a recent CPU. My guess is that even the latest desktop Core 2 Duo's could be fine. Just make sure you have hardware virtualization (VD-t VT-x / AMD-V) enabled. It is not really possible to run Windows in a virtual machine without that.

Also, not sure what your GPU is, but you might get better performance with proprietary drivers if AMD/NVidia.

Ok, I will give it a shot
Thanks

You mean VT-d? Is it really necessary, isn't VT-x enough? Albeit, maybe not for playing games.

Yes, I mean VT-d. And yes, it isn't. I mistook VT-d for VT-x. VT-x (AMD-V) is necessary (hardware virtualization). VT-d (AMD-Vi) isn't (IOMMU virtualization / hw passthrough). I'll better edit the post.

1 Like

Just checked on the BIOS and VT-x is enabled, I am at the moment installing windows7 on a virtual machine

Just installed everything, started metin and got the same error as running it under wine.
I guess GameGuard prevents the game from running on a virtual environment.

Try running the game as an Administrator. (Right Click + Run as Administrator) I don't know how GameGuard "improved" over the years, but virtualization used to work fine.

Try disabling Data Execution Prevention in the VM, since GameGuard is a rootkit and might collide with it.

There might or might not be a way to disable GameGuard completely and still play the game fine.

To disable I just add Metin2 to the programs exception list?

Tried running as administrator and the same error occurred.

Yes, and if that doesn't work you can turn it off all together as in the screenshot.

I found some people online saying that deleting the entire "GameForge" folder and reinstalling helps.

I just installed it fresh, why should I delete the GameForge folder? I would just redo all the steps I just did.

I tried both ways with the DEP and still no luck. (The default was like your screenshot)

EDIT:

  1. Windows Security update
  2. Certain Windows Security Updates may result in collisions with other security programs. We highly recommend you to update the latest version of Windows.
    • Windows update : http://update.microsoft.com/
      GameGuard control panel -> We recommend you to have the windows updated through automatic update settings.

http://www.gameguard.co.kr/eng/FAQ_114.htm

This may be the problem, I can't update now because my internet connection is data capped, will report back when all updates are installed.

Tried installing windows xp sp3 and the same problem is appearing.
I think it is time to give up, I can't identify any processes that are conflicting.

These are the processes running on the VM,
Imgur

It seems the "We don't care about VM users, they're using VMs only as an excuse to BOT" mentality affects this game as well, as I couldn't find a single working solution. I don't think I can help you, but you can try some of these bizarre ideas:

  • running metin2 with GameGuard sandboxed (for example using Comodo Firewall)
  • using Qemu instead of virtualbox (there is a frontend called Gnome Boxes for it)
  • Not playing metin2 at all (While this answer is unhelpful, you mentioned it is a time-waster)

It's a shame it doesn't work anymore, because Lineage 2 used to work fine.

1 Like

Really grateful for your help, maybe one day I will get this to work ;)

Hi,

i wanted to know if you found a solution to the problem

No, I gave up on trying to get it to work and stopped playing Metin.

Please don’t necro.

Also, if you were looking to play Metin in linux, the VFIO section is there for you to peruse.

Anti-Cheat spyware is sort of a major thorn for Linux gamers atm, almost ALL don’t work under proton/wine. Its a real shame.