Return to Level1Techs.com

Restoring a .cpl file to Windows Server


#1

I can no longer use Remote Desktop (RDP) to remote into a server (Windows Server 2008 R2) on the same LAN, because sysdm.cpl is now missing from the server. Can I simply copy and paste the file from another installation?


Here’s my notes…

Windows Server 2008 R2

I receive the following message when trying to connect using RDP:
SystemPropertiesRemote.exe System Error
The program can’t start because sysdm.cpl is missing from your computer. Try reinstalling.

sysdm.cpl
Process name: System Applet for the Control Panel
File location: C:\Windows\System32

From elevated command prompt i ran:
sfc /scannow
_ Result: could not repair all issues. See CBS.log (not included here, but i can provide if necessary)

Now I’m thinking I can just copy and paste the sysdm.cpl file, but need to obtain copy.
_ In Virtualbox, I installed evaulation copy of Windows Server 2008 R2.
_ I located the sysdm.cpl file, and copied to thumb drive.

Now, I’m just wondering if I can now copy and paste this single file to my active server, without creating any bigger issues.


#2

I doubt copying it in will hurt but seems strange that sfc /scanow did not fix it. sysdm.cpl can be called from the run box to open System properties so try that just to confirm there definately is an issue with it first.


#3

BGL, I thought the same thing about sfc /scannow not working. It did correct some of the issues, but not the sysdm.cpl.

I had even tried running it from the command line as you mentioned, but it couldn’t be found.

I went ahead and copied the sysdm.cpl file over from a usb drive. I can now get to System Properties, and get to the Remote Desktop settings, so that has solved part of the problem.

I still can’t remote desktop into the server. Perhaps it just needs a reboot, which I’ll do at the end of today.