Replacing unstable Ryzen 5 1600 with new Ryzen?

Hi everybody o/


Ever since I built my current desktop computer it has been unstable under Linux with idle freezes, random shutdowns and other crap.
It kinda worked for some time, but recently I switched from Arch to Fedora and updated my bios at the same time and it’s pretty much unusable now (I work exclusively on Linux).

I read all the kernel bugtracker and AMD forum posts and tried all the BIOS settings and C6 deactivation scripts and nothing helped. It seems that multiple people with the same motherboard / CPU combination had similar bad experiences.


Anyways, since I need a stable system for work soon, I want to replace the CPU (and maybe the motherboard?). Since I rarely check on new hardware unless I’m in the market my question therefore is:
Do you guys have experience with the current Ryzen models on Linux? Are they stable?
I’d love a system as stable as my 4 y/o Intel + Intel graphics. Thatone #justworks :wink:

My current setup looks as follows:

  • AsRock AB350M Pro4
  • Ryzen 5 1600
  • 16GB(2x8) GSkill 2133 Memory
  • Sapphire RX560
  • 430W PSU

If the newer Ryzen’s don’t show the same problems on Linux I would just upgrade to something like:

  • AsRock AB450M Pro4
  • Ryzen 5 3600
  • some more RAM
  • Sapphire RX560
  • 430W PSU

I’m not quite sure if I’d need the motherboard upgrade for the new CPU right away :thinking:

P.S. I hope it’s okay to post this into the Linux section, as I specifically hope to hear about Linux stability problems. The ones I had are hardly ever mentioned when talking about the first gen Ryzen, as they are mostly not present on windows.

1 Like

I can’t say I’ve had any stability issues with either my 2600x build or my 3600x build. I have to ask, have you run memtest?

To me it sounds like you have faulty ram, there’s no reason that a first gen ryzen system should be freezing so badly in linux. I’m running Fedora 32 on my ryzen 3600x and it’s been on for over a week with no issues, I can imagine that I’ll be able to leave it on as long as I want with no further problems.

Good point, I will start memtest right away.

However, I am pretty sure it’s the same problem described here and here.
From the AMD post:

but mostly the system just stops and I can find no logging that tells me why.

^ This is pretty much what happens most of the time for me, too.

It’s good to hear that you had no problems with your builds. What motherboard are you using?

First build is a GIgabyte x570 Aorus Elite, 32gb Corsair Vengeance @ 3200mhz (4 x 8gb), 3600x.
Second build is Asus strix b450, 32gb gskill ripjaws 3200mhz (2 x 16gb), 2600x.

The secondary build with the 2600x is now an esxi machine for vms but it was my primary system for a while running both windows 10 and kubuntu.

My newest computer. Runs well except 0AD plays up using an R5 3600. I found some new games to play.


Processor : AMD Ryzen 5 3600 6-Core
Memory : 32863MB (7116MB used)
Machine Type : Desktop
Operating System : Mageia 7
User Name : vk3bvp (Shane Deering)
Date/Time : Tue 09 Jun 2020 23:54:52 AEST
Resolution : 4480x1080 pixels
OpenGL Renderer : AMD VERDE (DRM 2.50.0, 5.6.14-desktop-2.mga7, LLVM 8.0.0)
Session Display Server : [X11] Mageia 12008000
-Audio Devices-
Audio Adapter : HDA-Intel - HDA ATI HDMI
Audio Adapter : HDA-Intel - HD-Audio Generic
-Input Devices-
Power Button : Keyboard
Power Button : Keyboard
Eee PC WMI hotkeys : Keyboard
HDA ATI HDMI HDMI/DP,pcm:3 : Audio
G-Tech CHINA USB Wireless Mouse & KeyBoard V1. : Keyboard
HDA Digital PCBeep : Keyboard
HD-Audio Generic Front Mic : Audio
HD-Audio Generic Rear Mic : Audio
HD-Audio Generic Line : Audio
HD-Audio Generic Line Out : Audio
HD-Audio Generic Front Headphone : Audio
G-Tech CHINA USB Wireless Mouse & KeyBoard V1. : Keyboard
G-Tech CHINA USB Wireless Mouse & KeyBoard V1. : Keyboard
G-Tech CHINA USB Wireless Mouse & KeyBoard V1. : Mouse
Logitech M325 : Mouse
-Printers (CUPS)-
Epson-Stylus-Photo-TX700W : (Default)
sdc : SEAGATE ST2000DM001-9YN164
sdb : SEAGATE ST4000DM004-2CV104
nvme1n1 : ADATA ADATA SX8200PNP
sda : WD WDC WDS240G2G0A-00JH30
nvme0n1 : Samsung Samsung SSD 970 EVO Plus 250GB
sdd : sStorage Device
sr0 : sDRW-24D5MT

The low end ASRock AM4 boards from the early days are not great. I have read a few stories and had one myself for a minute before I packed it back up and returned it. Board and PSU are the two components nobody should skimp out on. That 430W you listed, what is that and how old?

Also, what BIOS version did you update to?

It’s an Antec EA 430D PSU. It’s as old as the rest of the system (maybe 2-3 years).

I took several steps to update the BIOS as outlined here. First updated to 3.40, then 5.50, then 5.90.
After each step I booted into Linux and checked whether the issues were gone.

OK, just making sure. :wink:

My experience with that ASRock board was very short because it just wasn’t stable at all. I then went with an Asus A320M-K which so far is rock solid. I am running a R3 1200 and some ECC memory on it as a router. You can try to fiddle with the BIOS and disable all the power saving stuff as well as C-states and look what happens. If that doesn’t work I would switch the board first.

I’ve had an Asrock AB350M Pro4 with the same issue. There was a rather large batch where the system would just lock up after some time. I had it under windows, but just thought I’d let you know.

edit: I swapped it out for a MSI B350M Gaming and returned the ASRock

I went through pretty much all power saving settings already (Cool’n’Quiet, C6 states, typical current idle,…).

Are the new 450/550 series boards compatible with the old Ryzen generation? That way I could upgrade step-by-step, starting with the motherboard.

@Some_Tech_Noob: ah, very interesting to hear that it happened on windows, too. Now, I’m pretty convinced it’s a motherboard issue (aswell?).

I think it’s probably just a motherboard issue. Used the same CPU, swapped the board. Friend went from constant crashes multiple times a day to 0 issues.

B450 is probably your best bet, maybe the MSI B450M Mortar Max if you can find it. B450 is compatible with 1st gen, and MSI has promised compatibility with 4th gen if you want to upgrade down the line.

1 Like

Ah perfect.

I had a quick look around and it seems pretty hard to get ahold of one of these at a reasonable price, here. But I will look some more.

Thanks for all of your help!

Just want to point out that you can make your R5 1600 system more stable by adding this boot command. (My server was up 45 days at least before I rebooted it to apply a kernel update and sth else I can’t recall)

I’ll reformat the post when I’m back home