Repairing my ps3 controller (charge circuit wont work)

My PlayStation 3 controller will not charge its internal battery anymore, the battery is fine and it works plugged in except if the vibration motors gets set off it will then draw too much current and the controller shuts off. If I externally charge the battery it works correctly till the battery runs out.

As a temporary solution I removed the battery and even though its a little higher voltage than it should be I soldered a wire from the usb power to the battery terminal to directly power the controller.

To restore battery function I plan to add a a Module like this to replace the circuitry in the controller that dose not work, pull power from 5v+ usb to the Modules power input then connect the Modules output to the battery in then the Modules ground to ground and that should work.

Before I do this I was wondering if there was a better way to go about this. Maybe the gamepads charge circuitry is easy to replace and readily available or maybe there is a fuse or fusible resistor that is usually the problem with this. Something like that would be nice to know about if it exists.

Don’t send 5V to a 4.2V battery. That’s a good way to really diminish its lifespan, along with potentially causing it do release the magic smoke.

Depending on how much free space is inside of the PS3 remote, you can probably add a TP4056 module, to handle battery charging

This module won’t work if the under-voltage protection is built onto the main PCB, and NOT on the battery. You will need a different TP4056 board which can also protect the battery from under-voltage (3V ish).

What you can also do is try finding the part which has failed inside of the controller, and replace it. I wouldn’t be surprised if it’s using very common IC(s) for battery charging.

1 Like

the battery is currently disconnected the 5v is poweing the controller directly

Chips that do nothing but under/over-voltage protection are cheap and easy to come by, under-volt protection should not be a huge issue since the controller would shut off before it hits that threshold anyways

What happens when you plug the remote into USB to “charge the battery”? Does the controller send ~4.2V to the battery connector?

Have you looked up the datasheet’s for the IC’s on the PCB, and found which one controls battery charging?

I could not find it, a lot of the packaged components are unlabeled.

If I were you, I’d take a look at the two 5-pin IC’s near the battery connector. Wouldn’t be surprised if they controlled charging. If they have model numbers on them, look p their datasheet, find out whether it is outputting the correct voltage, and if not, find outt whether it is getting a signal to charge the battery.

What you could also do is pour rubbing alcohol (90% or more, NOT less) onto the charging circuitry, plug in USB, and see which passive component/IC causes the alcohol to evaporate. It’ll help you find out what component is getting hot and is likely faulty, and that way, you could replace the faulty component (using a soldering iron).

Also, how do you know the cable works? Maybe that’s the issue?

I know its not the cable because my controller in functional.

I think enacting my original plan is probubley the best course of action. Figuring out what part of the original circuit is broken replacing it and maybe being wrong seem like a worse action than spending 78 cents on a Module that will defiantly charge my battery and solve my problem.

edit: I purchased this because it was the cheapest Module that would work. I’ll probubley desolder the USB port before installing it and of course insulate it to prevent any shorts. I don’t anticipate any problems.

  • Getting service manuals is harder than ever (Piratebay does not even have them…)
  • There are at least 5 different PCBs used in the PS3 controllers

Could you take some good photos of the PCB (no glare, low noise, etc)? With some luck, I can find the datasheets for components and reverse-engineer the circuit.

1 Like

This right here ^^^ We’d be able to help you much better if we had high-res images of the PCB. I tried to find some already, but couldn’t.

Also, regarding the module you bought, you better hope that the OEM Sony battery has under-voltage protection built into the cell, or you’re going to kill that battery very easily…

Well high rez is not an option but i can try to take some pictures with my nexus 5. I do appreciate the input here. I do not want to come off outer wise.

As for under volt protection in this instance the voltage the controller shuts off at is higher than the threshold the battery would be damaged from being ran too low so it should not be much of an issue. Also the battery output is not being changed so any under volt protection built into the controller shouldn’t be effected.

If the consensus is I am incorrect about that overvoltage/undervoltage protection chips are cheap tiny and easy to come by I could always add my own.

gave it my best shot as you can see nothing is really labeled except the main IC the Toshiba T6UN6EFG-003 and that is a microcontroller made specifically for ps3 remotes and the information available in the screen printing

this is bord revision MSU VX3 0.07 and there is info available for it online

edit: I went ahead and erased the pictures I took because they are not particularity useful. The pictures linked below are the same board revision of the controller I own.

here are some images of my board revision found online that are clearly much better than mine

Can you get pictures of the other side of the PCB? There’s very few components on the side with the micro controller. Feel as though the other side will actually have the charge circuitry for the battery.

If possible, can you take pictures of the IC model numbers on the otther side of the board? If they aren’t clear pictures, can you tell us what numbers/letters are on there?

Why not pop off the usb connector and just solder a spare usb 5v line to the usb spot?
Just bypass the actual usb header and stick your power right on the pcb?

Because the USB port is not broken the problem is the battery is not getting charged. A lithium battery needs intelligent charging, its the intelligent charging circuitry that is not working.

1 Like

So its the charging circuitry?

Your initial problem reads like the battery itself is dead.

Have you tried a completely different battery?

Nope, as I said in my OP if I charge the battery and put it back into the controller it works fine. I know what is wrong and have already explained it

I read what you said, that doesn’t make the battery not suspect. Holding a charge for a bit when blasted but not holding a charge on its own is super suspect.