Return to Level1Techs.com

Remote management on the Asus Pro WS X570-ACE, under Linux?

This board is arguably the only really WS-like X570 board, and it has some unique features, the most interesting being this new Realtek RTL8117 NIC, that apparently can act like a BMC.

Has anyone tested this board? Especially under Linux? @wendell
I saw the Anandtech review, unfortunately they neglected to test anything remote mgmt related.

As far as I can see, the only way to connect to the “BMC-NIC” is via the ASUS Control Center Express software, that runs only under Windows. I can live with that. But the real question is how well do things work if the system with the WS board is running Linux? How much of the BMC-y things are inoperable?

Looking at the ASUS infographics, this thing is supposedly able to give “hardware level access”, and it is supposedly able to change UEFI settings, reinstall the OS and reset the system. So it looks like a functional BMC, but at the same time my BS detector is going off.

@densetsu

Didn’t you get one of these boards?

Yep. I got it up an running last night with the intention of installing the control software in a VM and messing around with it later. I still need to update the 8117 to the latest firmware because it complains about that at every boot. I will make a thread about it if there’s interest.

1 Like

A thread about the board would be neat. The ASRock motherboard thread seems popular at least.

Please do. We might end up buying 5-10 of these boards, if they work well with Linux.
Unless TR 3000 series drops and we decide to go for that.

Well so far there is no documentation that I can find for Control Center Express and login info is… who knows?

Apparently you can use the VM image as the board comes with a key for the CSM version of the CentOS based appliance. Trying to find the key though as I dropped the booklet behind my immovable desk lol.

Well, your BS detector was right. At least for now.
It doesn’t do much of anything. I can turn it on and off (without needing any kind of password btw) and that’s about it. You have to install the agent to do anything else and it’s Windows only. The CentOS appliance doesn’t see the machine at all. Overall, a pretty big bummer. Guess I’ll wait for X570 ASrock Rack. Not to mention there was 0 documentation. Then I get on with support and they kept sending me manuals for the regular version. Then they finally upload the manual AFTER I opened that case and just tell me I should have read the manual that didn’t exist before I told support there was no documentation.

2 Likes

Sounds pretty typical for ASUS support

Yeah. I didn’t expect a ton after they told me the IPMI chip for my other Asus board wasn’t a thing even though it was one of the main selling points lol.

So the RTL8117 cannot do much at all on its own, and needs the support of the Windows based client to do anything useful?

That’s what it’s looking like. I’ll be digging a little deeper today.

Any updates? They claim you can change bios settings and do installs with the control center which sure makes it seem like you wouldn’t need a Windows client for at least some of the stuff.

The features of the full version are worlds apart from the express one. I did get into it once they finally posted documentation on the site. But it’s more a “getting started” guide and less a full explanation of what you can actually do.

So the conclusion remains: can’t change bios and it’s totally worthless?

Sorry to revive the thread. I also have this motherboard, currently in my Unraid server. I’m trying understand how it work for management… can’t find anything. Also, when going in my browser and pointing to the IP of my NIC, I got this error :

/usr/lib/lua/luci/dispatcher.lua:533: bad argument #1 to 'pairs' (table expected, got nil)

stack traceback:
[C]: in function ‘pairs’
/usr/lib/lua/luci/dispatcher.lua:533: in function ‘createtree’
/usr/lib/lua/luci/dispatcher.lua:201: in function ‘dispatch’
/usr/lib/lua/luci/dispatcher.lua:168: in function </usr/lib/lua/luci/dispatcher.lua:167>

Googling this error seems to point to OpenWRT error, but there is no OpenWRT at all in my household (unless the BMC runs a version of that ?)

Also, how to update the RTL8117 firmware?? didn’t find a way to do that.

Have the board. Luckily got it for reasons other than the BMC, but played with it for a bit. Really seems like it is a windows only feature for doing most of the things you’d want a BMC for in the first place.

Thought about linux for future use with the board and its BMC, but the only driver and firmware updates for the RTL8117 firmware I could find was through the ASUS Armory Crate utility which is only on Windows (at least when I checked). So if you are driver whiz, you can find it that way and see if you can make it play with linux. If not, think the entire set up is a bit of smoke and flash and no substance as others have said already.

Sorry for bumping this, but it’s a few months later now and I find myself considering to buy this motherboard, but it’s pretty hard to find any info on it still. It seems pointless to start a new thread about the same topic while this one already exists.

I have a few questions that I’d love to see answered before I buy this board:

  • Have there been any (3rd party?) improvements on the BMC on Linux?
  • Does powering down remotely through Linux work consistently (powering up can be worked around through WoL)?
  • Can the BMC be isolated from the OS entirely, so it can be put on a management VLAN without the OS being able to access it or the VLAN?
  • Can the BMC be disabled entirely if need be?
  • Does the BMC get in the way of normal X570 features/UEFI BIOS stuff, compared to other non-WS x570 motherboards?
  • And finally, not related to the BMC, but does audio (i.e. Pulse) work OOTB?