Return to Level1Techs.com

Recent 18.04 install, some quirks, advice required

So I installed Ubuntu 18.04 on my dekstop machine, after windows 10, so I’ve got dual boot going, which is nice.

Still, a few quirks are popping up that I’m not sure how to tackle.

Some details

CPU - Ryzen 2700X
GPU - Sapphire Nitro+ Vega 64

  1. screendump outputs a big empty space. Running it without sudo gave :
>screendump 
/dev/tty0: Permission denied
screendump: couldn't read /dev/vcsa
  1. Middle mouse button isn’t providing that functionality where you can drag a document in various directions. it does close tabs and perform other functionality, but not this.

The mouse in question is a Logitech mouse.

  1. I’ve 2 monitors, the main one is an Acer monitor with speakers. I have to turn off pulseaudio for it to work properly. If I don’t, there’s constant cracking in the audio. So I run pulseaudio -k and that fixes it, normal sounds everywhere.

EDIT: Side effect of doing this: audio controls don’t actually work. Can’t mute, can’t make it louder, can’t make it quieter.

Due to this, I haven’t tried looking up anything specific for the graphics card.

Any help would be appreciated.

EDIT:

  1. Right, I lost my internet connection. ip a showed my ethernet card no longer had an ipv4 address. After performing sudo dhclient I had one again.

What even prompted that to happen???