Return to Level1Techs.com

Razer Blade 2020 Bluetooth (or how I spent a week troubleshooting this issue and found the fix randomly)

Hey All,

I’m a first-time caller long time listener but wanted to share an experience I had over the past week with my new laptop. Recently with working from home and the inability to split my work and relax space, I got a laptop that I could have elsewhere in the house that I can do more coding on.

TL;DR: With an Intel AX201 or AX200 on Linux you may need to disable co-existence mode directly in your OS in order to use Bluetooth effectively. This can be done by running the following command:

sudo tee /etc/modprobe.d/iwlwifi-opt.conf <<< “options iwlwifi bt_coex_active=N”

In my search for a new laptop, I had decided on a Razer Blade Base (2020). Originally was going to do a Stealth, but the keyboard small shift key on the right-hand side was a no go. I picked this one up and it has a second M.2 slot so I wanted to dual boot Windows and Ubuntu.

I like Windows for still doing some of my day to day work since a lot of my clients are in the Windows world, but Ubuntu so I could start learning to code and I’m super familiar with it. I’ve only been into using Linux more in-depth a few years but I wanted to spend most of my time in it on this one.

Anyway, this issue started when I did my first install on my new M.2 with Ubuntu 20.04. I have a set of AirPods and wanted to connect them to listen to music while I was coding. I attempted to connect and couldn’t connect. I assumed it was an issue with my headphones, but was able to connect with a few other devices.

The first thing I attempted to do was trying to connect with the Blueman package. Once installed I pulled up Blueman-manager, but it would let me trust the device however couldn’t connect. Wondering if it was a weird incompatibility I attempted to connect my Bluetooth mouse and got a similar issue.

After this, I restarted service a few times and finally opened up bluetoothctl to attempt to connect. Any device I connected to would just give me a BlueZ error. I would only say BlueZ error in progress. I attempted to remove and update all packages. I tried removing and reinstalling all PulseAudio. I went in and edited the bluetooth.conf to not do dual-mode and still had the issue.

At this point, I wondered if there was an issue with OS. So to test this I wiped and tried again with 18.04 and was getting a similar issue. Seeing other issues with this I tried all the same troubleshooting steps. Had the exact same results. Finally, I decided to see if there was a firmware issue and updated that. Honestly, the first time done on the Linux side but was super easy. Still ran into the same issue.

All in all, I had tried for 3 days on and off to troubleshoot and was very frustrated as everything that was suggest had been tried. So dismayed I decided to update back to 20.04 and just suck it up that there may just be an issue with Bluetooth on this laptop. Then I remembered maybe it’s the fact it’s a dual boot issue. I loaded into Windows.

Opening up I was able to pair in mere seconds. So not a problem for Windows. I removed it swapped over Ubuntu and still got the same problem. Finally, I decided to change my google-fu searches to focus on Intel Adapter Bluetooth rather than just generic Bluetooth issues. I tried with my model for the card and without my model.

Finally, after trying a few more things that honestly didn’t do anything and aren’t worth mentioning. I found an article for Intel AC adapters that states Intel’s combo chips have co-existence on by default and is known to cause issues trying to connect when enable. So I ran the following command.

sudo tee /etc/modprobe.d/iwlwifi-opt.conf <<< “options iwlwifi bt_coex_active=N”

I disabled it did a reboot and in mere seconds it was able to connect.

This is such a random issue, but I figured someone else might run into something similar, and hopefully, this has helped solve this issue.

Thank you for coming to my TED Talk.

John T.

2 Likes

Insight into why you went with Razer? (just curious as idk if i would have gone that route ) I have one I got it at the time cuz i like the design, probably wouldnt go that route again since there is gpu docks and some compelling ultrabook alternative finally

It was mostly due to the fact that it was in stock and I liked the look of the black laptop. Compared to the others that were available in store. Sidebar: I went to Best Buy since I had special financing and an Elite Plus Member. Although, things I do like about the model is the second M.2 slot, Ram is upgradable to 64 GB, and it does have a 2060 on it if I want to use it for any hardware acceleration. Build quality is pretty good. It also comes with a USB-C and a Thunderbolt port and I wanted a USB-C just so I can have a yubikey on it. The A variants stick out so far and the C’s are able to be pretty low profile.

1 Like