Return to Level1Techs.com

RAID 1 Underperforming

#1

Hi all, I hope that I posted this in the right category.

My goal is to get the setup below to run RAID 1 and benchmark within the specs of a single drive in AHCI. I read RAID 1 theoretically should at least read and write near the speeds of a single drive. I didn’t expect the performance loss in the benchmarks below. I’m hoping someone has a suggestion as to what I’ve may have done wrong or if there may be a limitation in my setup. The drives are on the mobo.

-System specs-
CPU: AMD Threadripper 2950X
RAM: G.Skill F4-3200C14-16GVK DDR4 x 4 - 64GB @ 2933MHz
Mobo: MSI - MEG X399 Creation
GPU: Radeon R7 370
OS: Win 10 Pro
NVMe SSD: XPG SX8200 Pro 1TB x 2

Benchmark tools:
-CrystalDiskMark v 5.5
-AS SSD v 1.9.5986.35387
-ATTO v 3.05

A single drive in AHCI here.

The drives are assigned to a RAID 1 array here.

As you can tell, the RAID 1 setup is not performing as well as a single drive in AHCI.

Any help is appreciated.

0 Likes

#2

Are you doing raid via firmware or using NTFS dynamic disks?

0 Likes

#3

I think we have some missing information here. If your doing it in the Firmware how have you done so list your steps

if your doing dynamic disk… software raid really isnt all that great

0 Likes

#4

I am using the “RAIDXpert2 Configuration Utility” in the BIOS. The BIOS is updated to the latest version, and I’ve tried both MSI’s and AMD’s latest RAID drivers as well with pretty much identical results. I followed the steps for creating the RAID 1 array in this clip.

MSI® HOW-TO Setup X399 NVME M.2 RAID

My thinking now is that Heimdallr (I’m also Norwegian) is right and that the RAID is controlled by software, but I’ll look into that more.

0 Likes

#5

Oof, that’s pretty terrible. Any luck? I was looking into an NVMe RAID 1 TR system as well and can’t find other benchmarks on that setup.

0 Likes

#6

Nothing yet. I’ll post here again if I find the source of the problem or solution.

0 Likes

#7

I tried amd raid 0 like you and saw the same degredation in performance for 4k1Q1T reads, worthless. Now I’m on windows software raid and its performance is great - 10% faster than a single drive for 4k1Q1T reads and about 80% faster for sequential reads.
Seeing as you want a raid 1 you might need a dedicated raid card, I’m only using my windows software raid 0 for primocache and to hold a vmware disk.

0 Likes

#8

2019-06-18-13-08-01

You have three m.2 slots. Do you have the drives in M2_1 and M2_2? For funsies maybe try putting one in M2_1 and the other in M2_3?

1 Like

#9

Just tried RAID 1 with two MP510s on an X399 Taichi. Sequential were fine and reads increased a bit (around 4100 MB/s).

4K QD1 dropped quite a bit and high QD 4K tanked like nothing I’ve ever seen.

It’s not just you. I think the AMD implementation is just junk unless your goal is RAID 0 professional benchmarking.

0 Likes