Radeon HD 7750 on Linux?

Hi guys, I’m just getting started with Linux on my PC, currently using an HD 7750 since my GTX 770 got roasted by a bad PSU - Is there anything I should know for getting it running smoothly? I’ve only tested a couple games so far, it works fine with BallisticNG, but I get intermittent freezing in Planetary Annihilation… sometimes it works fine, sometimes it freezes after a minute, sometimes after three. Even weirder, if get into a skirmish first, it won’t freeze for the rest of the session. Trying to figure out if it’s a problem with the game or a problem with my computer.

I’m on ZorinOS 15.1 (Ubuntu-based), kernel version 5.4.3. Haven’t messed around with PPAs or anything like that yet.

Should be fine… Not a powerhouse of a card but I use one for testing purposes. Could be a game or settings issue as the card is pretty old and more of 720p card. It does 1080p but not well at gaming levels.

Should be, for sure. Gonna install some more games tonight and see if any other weirdness comes up. I was looking up AMD driver installation a few days ago (before I realised the drivers are built into the kernel these days - that blew me away after a lifetime of Windows) and found a bunch of stuff about getting this or that PPA to make Mesa work or what have you, so that got me wondering if I just missed a setup step. Is that something you still do?

A testing card now for ruling out bad gpu ect…or lost a gpu and nothing else on hand atm. Drag it around with me.

I imagine it would struggle greatly with modern games. Some retro games would make more sense.

Gaming on linux with pop os and 2080 at 1440p atm :slight_smile:

Yeah, that’s an AMD only thing. Nvidia still does separate drivers you have to install. (or you can use the open source ones that are a bit less efficient)

That said, the older amd cards are a bit of a mess, they have amdgpu, which is the “current” driver, basically for R series and later cards. Then there’s the Radeon driver, which is for the older cards. (yours) I can help more when I’m at my workstation if you’re concerned something is not right.

1 Like

I had a hd 7870m and it works very bad on linux.

Alright, tested out Hollow Knight and Stellaris… no weirdness with either of them. I guess the older AMD cards just don’t like PA?

A new graphics card is on my list of things to buy anyways, gonna wait until the RX 5500 is out before I make a call on that. I guess if the problem persists I’ll dive back into troubleshooting mode. Thanks, guys.

Weird chip. You should make sure Zorin isn’t forcing it to run with AMDGPU as the 7750 is one of the chips you CAN run with AMDGPU, but you probably don’t want to for very long. You get the same performance, or even damage in my case with my R7 370, as you get with your card. Sometimes works, sometimes really fucky.

If you ARE running AMDGPU on the card, blacklist it so the card only runs on the ati open source drivers. You can look up how to do that on the archwiki.


I ran PA on a pentium 4 and a winfast PX7900GT. Took forever to render the map in pre-game, but ran at 46FPS regardless. PA doesn’t have a GPU constraint and actually does favor AMD GPU’s in OGL performance, I’ve found.

Try Vulkan.

Edit 2: 7750 is technically a 260/260X right? Never honestly checked.

@FaunCB Okay, I think I figured out what I need to do to blacklist a module, but all the config files are read only - should I make a new one? Is there a specific way I need to set up the file to work properly? Also, is there a way to check whether AMDGPU or the Radeon driver is in use?

Edit: No idea about the 260/260X relation.

lspci -v will tell you what modules are loaded where. You’ll have to scroll up some till you see vga compatible conhroller or something.

Well, lspci lists radeon as the kernel driver in use, so that’s that ruled out. On the upside, I can answer the rebrand question - it’s the R7 250E that’s a refreshed HD 7750 (and so was the HD 8740, for that matter).

Try Vulkan.

So, I guess that’s next on the list. How do I go about that?

Also, for reference, here’s what lspci returned on the card:

Flags: bus master, fast devsel, latency 0, IRQ 55
Memory at e0000000 (64-bit, prefetchable) [size=256M]
Memory at fcf00000 (64-bit, non-prefetchable) [size=256K]
I/O ports at f000 [size=256]
Expansion ROM at 000c0000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: radeon
Kernel modules: radeon, amdgpu

The HD 8000’s were just 7000’s but it said Dell at the start.

Game settings. Sometimes in steam settings. Theres also something out there to run OGL code in vulkan that works pretty good but I forget the name. @wendell or @FurryJackman might remember the name tho.

If you run anything in wine/lutris you can force it to render in vulkan, for note.

Edit: Also looking at the data sheet on the card

Bump that memory clock up a bit if you can and you’ll see a jump in frames.

I ran an R7 250X and streamed with it. You should be able to OC the ram on that 250E and get some pretty good performance out of it for what it is. (honestly want a 250X again I liked that card a lot)

Honestly dude its really not that fast of a GPU and gaming on Linux is a meme.

Acquire the old “Radeon driver” amdGPU only worked on pitacairn pro and upward from my understanding . Its a huge mess and lol nvidia is better on Linux right now.

Also don’t let anybody tell you to distro hop if it occurs realize its a disease that destroys productivity. All Linux is the same kernel with an OSand a shell with slightly different defaults and they all suck and are awesome at the same time.

Zink is what you’re looking for if you want to do OGL to Vulkan, it’s supposedly targeting inclusion in Mesa 19.3: https://www.phoronix.com/scan.php?page=news_item&px=Zink-OpenGL-Vulkan-Mesa-19.3

But it looks like you’re not running the Mesa amdgpu. You’re on GCN Gen 1, so you’re SOL, because GCN Gen 1 is only “stable” with the radeon driver rather than amdgpu. You may as well get a RX 570 4GB, because the 7750 is not designed for modern Mesa at all.

Use the Kisak Mesa PPA once you get your RX 570.


Guess that about wraps it up, then. That’s all good stuff to know. Cheers, mate.

1 Like