Return to Level1Techs.com

R9 280X screen flicker Fixed

helpdesk
windows

#1

Picked up a used R9 280X. It works great for everything except this screen flicker.
Using AMD drivers 18.5.1
Every thing I have see online is to raise the low end gpu and ram frequency up from 300mhz gpu and 150mhz ram.
The latest drivers do not have an .xml in the location people say it is in.
Getting rid of this flicker would be great.
Do not want to go back to a GTX 560.
Thanks


#2

Is it only present with Windows, or also in the BIOS/UEFI?


#3

In Windows have not tried it in Bios/uefi

The problem just started today this card has been in my machine and working 4 days.
Could a program start this problem, because after supper I do not have any flicker.
I had Steam open on the desktop, Firefox and thunderbird open when it started.
And the flicker only happens when the gpu goes into power saving mode. When I start a program that ups gpu usage then it does not flicker.
Just a few observations.
Will have to see if this is something that is just here or there when some programs run.
Problems like this are very hard and annoying to fix.
If anyone has some insight to this kind of problem would like to hear for you.
Have a day


#4

Just to test I opened steam up and went to the store and then the flicker or screen jumping started.


#5

Is there an easy way to change the settings for the gpu and memory on the r9 280, when the gpu goes into its lowest state it drops down to 300mhz on the gpu and 150 on the memory.
I would like to raise this to something higher.
From what I have read wattman does not work on the r9 280x and in there I could fix this easy.
I do not like when the gpu drops that far down when it is not doing anything. Would prefer it to stay near its max clock speeds.
Is there a program that works like wattman and allows you to change the power states on the gpu.


#6

I sort of have a fix for this problem, just not a great one.
Downloaded Asus Tweak 1 clicked on the 2D settings and up the clock speeds to 800mhz on the gpu and 1000mhz on the memory.
Does anyone know of a way to do this with out using Asus Tweak, I would like to know.


#7

The Asus Tweak fix was more like a cut down of how many flickers happened, it cut it down a lot but not a complete fix.
Did a clean install of Drivers.
Went back to a restore point.
used Guru3d DDU to remove drivers.
Uninstalled MSI afterburner Asus tweak 1 and 2, found all files a folders I could and deleted them.
Ran CCleaner registry cleaner 3 time till there was no fixes for nvidia or amd and the first clean there was a lot of both.
checked windows update
did a restart
checked windows update
ran CCleaner again there was nothing.
This as clean as I could make it with what I know.
Shutdown PC turned power switch off on power supply, waited a few min, repowered PC and started PC.
Did all the checks again to make sure there was nothing around made sure Microsoft did not install some older AMD dirver like it did one other time I did all this. Checked hardware to make sure Display driver was just a Microsoft driver, then installed AMD driiver 18.8.2 aug 27. Checked Window for updates.

Thinking back problems started when I start MSI afterburner and Riva tuner to test Skyrim SE and how it works
This is the same MSI afterburner that I had installed and was using on the GTX 560 for overclocking. Do not know if it could contaminate things along with all the still in system registry from Nvidia. After using MSI afterburner was when problems started. Just put info down in case someone else on internet reads this and has the same problems.
Will see how this works and if the screen flicker / jumping stops.

If this does not work will backup current info and wipe all drives and fresh install Windows 10.


#8

Hi. I think you’re just experiencing Artifacts. They can come in a variety of forms.
The 280X is very well known(atleast at launch) to have alot of issues with artifacts.

I had one myself, with quite nasty artifacting.
The things I noticed were:
Flickering textures.
Textures not appearing.
Textures “popping” out, looking like my monitor was 1/5th a piechart.

I only think underclocking is the solution to this issue.
But hey! I don’t know ^-^!


#9

Will try underclocking
It is not really a flicker it more like the screen jumps up an inch then back to normal.
Only happens when in 2D more, in games it works great, but firefox and anything on the desktop does this screen jump.
Will give underclocking a go and see what happens.


#10

Thanks for the info, did some research into the underclocking, and got the best answer to the problem.
The Asus R9 280x DCII Top underclocking the ram is what fixes the problems, Asus clocked the ram at 1600/6400mhz and did not put any heatsink on the ram to keep the chips cool fan curve starts at 20% and stays there till close to 60 -70 C then ramps up. By that time the ram is to hot and starts artifacting.
I underclocked the ram down 1450/5800 mhz and pushed the fan speeds to 43% just high enough so I do not hear them. Have been playing games then working 2D desktop all day and not one of the screen jumps. If this is the fix will bring up the ram speeds up to 1500/6000 mhz, and leave it there.
Thanks Cutie for put me on the right track. Asus just had to make a better cool, or just put some heat sinks on the ram, or have a better fan profile and these would have been great cards out of the box.
Will run this way for a few days to make sure problem is fix then change the Header to a full fix.


#11

Do you have a other monitor/ cable or other pc you can test the card with ? did you test a other mainboard slot yet or a older driver ?


#12

Nope, looked up the card and found the people who had success with fixing the flicker, and the only thread that had a fix talked about underclocking the ram. And after the underclock there is no problems no screen jumps, just a proper working gpu. Did try an older driver not by choose just something windows decided to install and it did the same thing that was a Drive starting in 14.?.?. Did try a DVI cable, same thing. Did not try a different monitor did not have one. Asus from what that thread was talking about was putting 1.6 volts into ram that was made as 1.5 volt ram, increasing the voltage is not a problem, but asus did not put any heat sinks on the ram, and that is not a good thing to do.
This is just my point of view, on this problem, Asus did not make the card right and this is what I did to fix it.

Thanks for the input Unexpected.


#13

That card seems to be borked get a used other card I think you are gonna be more happy with a other card my friend had a 280 x before he bought a 1060 he hadn’t had these issues you had that card seems to have a problem you can’t fix I guess maybe you find a solution :smiley: