Return to Level1Techs.com

Question on USB C, Networking, and this dongle I bought

linux
pop_os
#1

So my ethernet port on my laptop doesn’t want to work in linux. Why?

Killer networking.

My model is an MSI GS63VR. Yes I tried to sell it. Yes I still have it. Regrettably. But possibly its better to try and make use of the machine than to ignore it.

But anyways, I have a USB C port and 20 bucks so I got an adapter to hopefully fix this issue. I figured it’d be cool to use thunderbolt for something, and I don’t even use the port rn anyways. Thing is, it doesn’t seem to get detected.

So how does this work? Does the adapter take internal ethernet and use that, or does it have its own chipset? If most of these have their own chipset, what company does Belkin usually buy from? I just bought the basic 25 dollar black belkin adapter at best buy.

I thought I’d plug it in and it’d just work but apparently not. It doesn’t show up in the TB manager in gnome, in the networking hardware list, nor in connections. So, its not getting detected. But I know the port works because my backup drive boots up and moves data just fine.

https://www.bestbuy.com/site/belkin-usb-network-adapter-black/5476000.p?skuId=5476000

0 Likes

#2

Does it show up with lsusb? If it does then at least you know the device is functioning enough to give you some info. lsusb should show an ID code you can look up online and possibly get the chip info to search for the drivers. You can run it once w/o it plugged in and then plug it in and run again to figure out which one is which.

0 Likes

#3

What dongle did you get?

0 Likes

#4

edited op

1 Like

#5

[email protected] ~> lsusb Bus 004 Device 002: ID 0bda:8153 Realtek Semiconductor Corp. RTL8153 Gigabit Ethernet Adapter

yup

I forgot about LSUSB. It might be a driver issue.

1 Like

#6

As much as I don’t like Killer networking chipsets, your mileage is going to vary much more with USB as not all ethernet adapter makers design them for durability/thermal factors so they either fall apart or slowly overheat/experience BGA solder fractures. The last time I used a USB ethernet adapter for desktop usage as a 2nd NIC, it would overheat and routing performance would degrade.
Most OSes it’ll just be listed as a 2nd ethernet adapter, if there isn’t a cable attached it’ll remain inactive. Since you’re using it on a system with its own NIC, you’ll need to move the RealTek to preferred connection once the driver is installed.

As far as the RTL8153, I think its fairly recent that many distros don’t include the driver by default–hmm, tested a ethernet USB-C hub and it uses the same chipset.

1 Like

#7

Well it works at least.

0 Likes

#8

Ok so I went out and found the RTL8153 source and built it and installed it but it just wants to say that its r8152 and it doesn’t connect. Hell the damn thing even pops up in the networking menu in gnome.

Uhhhh. Wat do?

1 Like

#9

Did you try manually connecting via the terminal?

0 Likes

#10

You know I had’n’t really thought of that I kinda just expect it to just work. Like everything else lol.

I’ll try that.

1 Like

#11

Back when I ran chakra Linux, I had to manually connect via the terminal as KDEs networking thing never found my WiFi card.

0 Likes

#12

Hmmmm. Concerning.

My main ETH port is just… gone. Not even listed in ip…

1 Like

#13

Just followed this:

computer still said fuck you

You know with everyone so hot to trot on USB C and TB shit you’d think this would work better as its a commonplace adapter literally everywhere.

1 Like

#14

I give up fuck this pile of shit I’m pulling a desktop out of storage.

1 Like

#15

It would probably work on a Mac or on windows. Just saying. Lol.

I’m surprised that even doing it thru the terminal didn’t work.

0 Likes

#16

If it has to run windows its being sold. No security risks.

Or smashed with a hammer.

1 Like

#17

Does it work off of a live cd of < insert popular Linux distro here>. Maybe it would work on something besides pop

0 Likes

#18

I’m open to suggestions.

0 Likes

#19

Stock Ubuntu? Or maybe fedora.

0 Likes