PSA: is Firefox bugging you about rating it or updating it? Turn off Heartbeat!

Honestly surprised no one has spread this solution around for all of us who are privacy centric…

So Firefox has a feature that phones home to gauge how users like “the Firefox experience” called Firefox Heartbeat. You cannot turn this off from the UI. *grrrrr*

So you have to go into about:config to turn it off by setting 2 values (and they have to both be changed)

(boolean) browser.selfsupport.enabled = false
(string) browser.selfsupport.url = (nothing)

Hopefully this will be helpful for those of us that don’t want Firefox to randomly phone home to explicitly ask us to “gauge” our experience.

Edit: Well, that didn’t work at all… even with those values set, it still phoned home.

One more tweak then:

(boolean) browser.uitour.enabled = false

IDK if that will help, but it’s worth trying.

Edit 2:

BINGO. Looks like some forks of Firefox (and definitely your vanilla version of Firefox) forgot to disable the “extension.shield-recipe-client*” strings. For good measure:

(string) extension.shield-recipe-client.api_url = (nothing)
(boolean) extension.shield-recipe-client.enabled = false

This could also happen with a dirty profile. Best to check your profile about:config settings if you migrated from vanilla Firefox to a fork. Make sure the “extensions.systemAddonSet” string does not have “shield-recipe-client” in it.


Firefox can update all it wants. I don´t care as long as it works.

I switched to Waterfox and Firefox ESR because of all the power user features removed over the years. You can’t even globally disable Javascript anymore. It’s only on a per page basis.

1 Like

Yeah because the modern web demands Javascript. At least for modern web applications. Static pages don’t need Javascript so itd be fine to disable it for those. The only way turning js off would be useful would be to block tracking scripts, which extentions do anyway, and blocking crypto mining scripts.

I run ff nightly, so I’m gurenteed updates regardless.

Why not noscript?

1 Like

I only need it for one thing: preventing pages from disabling context menus. That used to be an “Advanced Javascript option” in the UI. Now it’s buried in about:config…

How are you finding noscript on the new FF?
It seems pretty awful to me, and the temporary allow per page seems messed up…
Or probably I need to rtfm

No, it’s not just you. Web Extensions basically just made all extensions only operate at the same level that extensions on Chrome does, so it’s absolutely not blocking the stuff at a network level anymore. This is why XUL was superior, cause it allowed pre-blocking on a much more lower level in the browser.

I don’t like the new interface, but I just imported my settings, so I have not needed to mess with the interface too much