Proxmox Ubuntu guest running an Apache Guacamole Container

alright so, Apache Guacamole is single threaded for it’s idk transcode process, “rendering” I guess.

So if I’m remote, and want to watch a video, or a large video banner ad pops up, if the cpu on the Guac server can’t handle it, it can lock out our input.

I found this to be the case on an old E5-2667 v2. So I installed proxmox on an old 4790s system and got pretty good performance.

Well a few weeks ago, I got a new PC, hooray!
A Ryzen 9 5950x, I loaded proxmox up on it again, iommu’d the gpu for my windows guest for gaming and thought about all the headroom I had on this new machine.

I moved my Ubuntu vm over which had the Guacamole Docker container on it expecting to just have buttery playback, and performance was worse than on my old xeon.

I’m passing the cpu as host, allotted it a bunch of cores.

I’m at a loss.
Is there some sort of AMD trick I need to do to get Ubuntu working well for my guac needs? Or is there some sort of optimization missing from Guac?
I also tried it on a LXC Container, same poor performance.
So weird.

Thanks for any thoughts,


I haven’t really used Apache Guacamole a lot. A few things I would try (probably you already tried some of them):

  • Proxmox VM CPU Type: Have you tried changing the CPU type from the default kvm64 to host ? ( maybe also check cpu flags in the advanced section )
    Whats the actual cpu usage when your are using it?

  • Destination: Is the destination your windows guest ? Do you use RDP? If you want to watch videos you may have to look at something else? (maybe give SPICE a try?)
    EDIT: SPICE support is in progress: [GUACAMOLE-261] Support for SPICE protocol - ASF JIRA

  • Browser: May be stupid. But I have noticed differences between Chromium based browsers and Firefox. Did check out different browsers?

  • Connection: Whats the connection to your Destination. Just the default Proxmox Linux Bridge?

  • Docker: Do you use any cpu flags to run it? (per default there should be no cpu restrictions). Have you tried to temporarily check with –privileged? There are some security features that may hit your performance. (search for: “docker seccomp performance”)
    How did you install docker? (, docker-ce, snap)