ProxMox broken

Went to Update and Reboot Proxmox the other day and it was broken. My VM’s were working, for the most part. I could access the web consoles, SSH, and transfer files to and from the VM’s but none of them were able to update. I then tried to restart the VM’s but none of them would boot back up. Tried to update Proxmox but that failed with DNS issues. On reboot of Proxmox i now have errors that keep it from starting normally. instead of the “access proxmox from this url” there are error messages about bios bug and failure to start ramdisk and boots into command line.

I do have snap shots and backups of data, but if anyone has some knowledge on what had happened I would appreciate.

1 Like

Seems like there is an mounting issue. The top most message about the volume group pve that was not found is whats wrong here. All other subsequent error messages seem to stem from this as a root cause.


Well it still does boot into the OS. Do you think it is recoverable from CLI or should I reinstall from back ups?

1 Like

A volume group is a unit used by LVM that contains volumes, that are a bit like partitions. Depending what is on them you might need them. It could also be a wrong entry and that your system thinks there should be volume group but you never had this one. Should be recoverable from the OS as long as the tools you want to use still work.

1 Like

So I am a Linux noob. I went to just reinstall and am running into the same issue. Tried cleaning the disk with a windows USB and diskpart, but these errors are persistent and I can not do a clean install. Any ideas?

1 Like

I think this is your issue.
I used zfs raid on my root partition, but I think default proxmox install use LVM, if you are missing a parition, the os will not boot.
Do you have access to the recovery cli ?

EDIT: also, check your bios, see if you did not lost a drive.

1 Like

All the drives are reporting. No smart errors. I did use Fdisk when I had cli access and it did say partitions 1 and 2 did not start on physical sector boundaries. That was the extent of my troubleshooting before deciding to do a clean install.

Unfortunately, I cleaned the two ssds with Windows diskpart and I no longer have proxmox cli. Because I have all of my data, I thought a clean install would be faster than digging through the OS. But now I cannot reinstall proxmox. When I tried to reinstall it fails with an option to view details. The errors are the same ones that I had with proxmox installed. I can post images tomorrow if you think it would help. Maybe I need to partition the drives with a Linux OS?

In bios everything seems fine. I even reflashed latest bios, set optimized defaults, and double checked that I turned on all the virtualize related settings with no luck.

I also don’t think it’s cpu, memory or sata controller/chipset related but those were my next thoughts for troubleshooting.

Little update.

I managed to get proxmox reinstalled! I think “cleaning” the disk with diskpart was insufficient. With a Windows installer I got to the page decide which disk you want to install and deleted all partitions. After that I was able to install proxmox. Everything is working but I still get some errors when booting. the web gui is now functional.

New issue. My truenas storage pool is listed as unhealthy. All the disks passed smart testing and nothing looks out of the ordinary except one disk, da4p2, shows “17” under “Read” while all other disks value is 0. I scrubbed the pool and rebooted the vm but it still is listed as “unhealthy.” Any ideas?

Thanks in advance =]

Hey there, I was about to mention clean install in last resort but you are already there!
I don’t think you need to wipe the disk if you want to reinstall proxmox.

Anyway, install Ubuntu or any other Linux in a USB flashdrive. Then boot on the usb and clean all your proxmox drives partitions with fdisk.
Don’t know what you did with diskpart, but I rarely use it.
I find fdisk more reliable.
While you’re at it check if you have your disk in MBR or GTP. Prefer GTP to MBR.

No idea for your truenas VM.

Try with the new proxmox restore the VM and see how it goes.