Proxmox 8.1.4 / PCIe Passthrough Issue

Hello Everyone, I am not an expert, and using linux/proxmox for the first time and trying to setup a home-lab.

I am trying do a PCIe Pass-Through for the Audio & Wifi to a Linux VM and getting the following error -

TASK ERROR: cannot prepare PCI pass-through, IOMMU not present

I have tried adding GRUB_CMDLINE_LINUX_DEFAULT=“quite intel_iommu=on” in etc/kernel/cmdline but had no go. :frowning:

Did you enable IOMMU on the motherboard?


Thank you for your quick response! @mutation666

Yes, IOMMU is enabled in BIOS.

I am using a ThinkCentre M80q, and I’ve also checked with Lenovo Support to check if there is any known issues with the firmware but it seems to be all all fine according to them.

are you booting to a zfs pool?

actually what steps in this guide have you completed for sure? then we can work on what else needs done.

1 Like

Thank you, @Zedicus!

I am not booting to a ZFS pool. Proxmox is installed on a single SATA-SSD.

The only thing I have tried is adding GRUB_CMDLINE_LINUX_DEFAULT=“quite intel_iommu=on” in etc/kernel/cmdline.

Checking the link now that you’ve shared!


Gave a quick read to the article.

The “iommu=pt” part was missing in the configuration that I updated to the etc/kernel/cmdline. Now that I have added it, the issue is resolved.

1 Like