Return to Level1Techs.com

Proxmox 6.2-4 TASK ERROR: IOMMU not present (Solved)

Alright, I need an adult.

I’m trying to pass a sas card and an Intel nic to a vm in proxmox, aka pcie passthrough. I’ve gotten this to work on an old supermicro mobo but I’d like to deploy a more pedestrian solution to a remote location.

I digress, the motherboard is ASRock H97M Pro4 and the cpu is a i7 4790s, both of which support VT-d.

I have enable VT-d and Virtualization support in the bios, and I have enabled intel_iommu=on in grub and preformed an update-grub with a reboot.

And still I get “TASK ERROR: IOMMU not present” when starting the VM.

I didn’t have to do any tricks with the server grade gear, why is this not working? Ideas?

Thanks!

First thing, off the top o’ me head, why not just use ZFS and create a vdisk, and just make a tap with the NIC and only assign said VM to it? That’s what I do and works well enough for me.

As for why, I think virtualization will work, but I’m not sure that H97 chipsets regularly had IOMMU in any manageable form for an admin. But this guy got VGA passthrough going, so my bet is probably on hitting that CSM support option on if it isn’t.

SMH,

Thanks for your fast reply, it encouraged me to continue searching. Also great article find.

I was updating iommu on GRUB but was booting ZFS. I did that on two different motherboards too. Man I am dense.
iommu
So we can label this solved.

Thanks again,!

1 Like

@chromefinch how did you set the cmdline file to have IOMMU working correctly?
Thank you!

I think the issue is you’re using grub to boot to zfs to then boot proxmox, so you want to update the iommu status in the 2nd boot. #bestguess
I plan on using a hardware raid 1 in the future (two m.2 ssd’s in one 2.5 adapter). I’m not convinced removing one of the zfs drives will result in a boot, I’d test both, one at a time.

nano /etc/kernel/cmdline
add this to the end of the line:
GRUB_CMDLINE_LINUX_DEFAULT=“quiet intel_iommu=on”
pve-efiboot-tool refresh

Thank you very very very much!!! you’ve solved my problem!! the right syntax is add “intel_iommu=on” at the end of /etc/kernel/cmdline
that’s because I’m booting as ZFS as you told me.
Thank you again!!! :smiley:

1 Like

Yeah man! That’s great!
Glad I could help,
Finish our your portfolio! Hang out a while, it’s a pretty cool forum.