Problems with LSI HBA + NetApp disk shelf + Windows 10

I’ve looked all over the internet without much luck so maybe someone here can help me.

I’ve had a NetApp DS4246 that I’ve had for a few months now, which I acquired from a reputable source. It has two IOM6s installed. I recently bought an LSI 9207-8e from a different reputable source and it came configured with firmware version 20. I also have a QSFP+ (SFF-8436) to Mini SAS (SFF-8088) cable which I’m convinced is fine (for reasons I’ll get into below). I currently only have two 12TB SATA HDDs.

I’ve been pulling my hair out trying to get this to work with my system for days now. I’m running Windows 10 Pro, and switching to a different OS isn’t an option unfortunately. The behavior has been super inconsistent and erratic. 99% of the time, when I connect the disk shelf, only one of the two drives are detected. The behavior switches up from time to time but tends to stay the same for at least some duration. For instance, for a while, every time I unplugged one drive and plugged it back in, that drive would become the detected one, and if the other drive was the one being detected previously, it’d disappear from the system (not just unmount, but it’d be gone from disk management too). Then for a while only one drive consistently would take priority and if the other drive was reconnected, it’d have no effect.

I could constantly unplug and replug the connectors and every time only one drive would come up, but on extremely rare occasion, both drives would connect and mount properly, and during those times, I’ve tested reading and writing to both drives.

I found someone online who claimed to have been using the same HBA with Windows 10 Pro without any issues, and was able to get in touch with them. Turns out they were using an older version of the firmware, so I tried flashing the same firmware in the hopes that it would resolve the issue. After a few reboots and reconnecting everything, I thought it worked for a bit, but turns out it was just another fluke and shortly afterwards it went back to only detecting one drive. I tested another version of the firmware as well, with no luck.

At some point during all this, the HBA was checked in its BIOS as well and it is detecting both drives. After a while, I of course began to suspect the cable, but this was quickly ruled out. Every time I boot into Linux, both drives connect immediately, on every reconnect of the cable. If I’m in Windows and only one drive is being detected, and I don’t touch the cable at all and reboot into Linux, both drives are there. Same the other way. I also installed MegaRAID on Windows and its able to see that two drives are present in the disk shelf, even though Disk Management doesn’t show it.

By now I didn’t really know what else I could test, so I purchased a LSI 9200-8e from the same source I obtained the disk shelf from. They weren’t sure why I was having issues with the 9207, but they told me that 9200s are all they ever use and that they work fine in Windows. In fact, they demonstrated this for me firsthand when I was at their warehouse the first time around when I purchased the disk shelf. However, when I installed it into my system, I immediately had the same issues that I had with the 9207. I tested both cards in different PCIe slots as well with no change. Out of desperation, I tested the cards in an entirely different system I had on hand as well, and they behave the same way there too.

What the hell is going on? I know these cards can work in Windows. There’s numerous reports of this online, and both of my sources tell me this should be working as well. Does ANYONE know what I can do at this point?

Haven’t used Windows with my disk shelves but hope to help anyway…

Since the drives appear in the LSI bios as well as linux, One could assume it isn’t a drive or hardware issue…

I know the way Windows automatically mounts drives can be very picky sometimes. If the drives aren’t presented in the exact way Windows wants, it will just not list it at all. 2 questions…

  1. How are the drives formatted? (4kn? 512e? something else?)
  2. What driver are you using? Just the one from Windows?

Well like I said, at times, both drives were visible in Windows independently (as well as together on rare occasion). Both drives were freshly formatted from that system as NTFS. I looked everywhere for alternate driver downloads, even just to try an older driver or something, but I couldn’t find files anywhere. The person I was communicating with online is using the same version driver as I was however, with no issues.

I’m usually good with figuring out stuff like this, but I’m at a complete loss here. Everything points to my hardware from top to bottom being fine and the issue being 100% with Windows, however I’ve seen plenty of reports saying it should be working just fine (as simple as plug-and-play even) with Windows. The only other thing I can think of is that both systems are B550 platforms, but I can’t imagine that’d make that much of a difference? One system is a Asus TUF B550M, and the other is a Gigabyte B550 Vision D-P. Unfortunately I don’t have another system to try it on at the moment.

I would proceed to do a sanity check.

  1. Plug the SATA drives via the mobo SATA ports, do they work? If so format them and see if you can copy/read data.

  2. In BIOS is the SAS card recognized as a PCIe v3.0 card and at 8x ?

  3. Do the SAS cables work? You said this vendor has similar setup can you have them test the cables?

  4. Have you tried different cables and possibly direct SAS to SATA cables without the DS4246?

  5. Can the vendor you bought the DS4246 shelf test the shelf in their setup? I have had bad IOM6 modules which seem to work but fail for certain functions.

  6. If all check out then time to see if its a BIOS version issue or SAS Card firmware issue, need to read the docs for both to see if there is any listed issue resembling yours.

This topic was automatically closed 273 days after the last reply. New replies are no longer allowed.